Bug 20307 - Flash player 9 (and 10 beta) with nspluginwrapper causes a crash
Summary: Flash player 9 (and 10 beta) with nspluginwrapper causes a crash
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Critical
Assignee: Nobody
URL:
Keywords: Qt
: 29555 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-06 13:36 PDT by Kyle
Modified: 2009-10-05 05:21 PDT (History)
4 users (show)

See Also:


Attachments
The console output and backtrace (6.52 KB, text/plain)
2008-08-06 13:38 PDT, Kyle
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle 2008-08-06 13:36:55 PDT
Arora (recent git) built against webkit svn trunk crashes with sigabort when attempting to load up flash via nspluginwrapper (on x86_64) .
Comment 1 Kyle 2008-08-06 13:38:50 PDT
Created attachment 22687 [details]
The console output and backtrace
Comment 2 Jocelyn Turcotte 2009-10-05 05:03:44 PDT
*** Bug 29555 has been marked as a duplicate of this bug. ***
Comment 3 Jocelyn Turcotte 2009-10-05 05:21:16 PDT
Can't reproduce the assert failure with nspluginwrapper 1.2.2
By looking at the log and backtrace I suppose this was caused by the same QtWebKit behavior as bug #25053.

Please try again with the latest QtWebKit trunk if support for nspluginwrapper 1.0.0 is necessary.