Bug 200012 - [iOS] Fix mach lookup sandbox violation
Summary: [iOS] Fix mach lookup sandbox violation
Status: RESOLVED DUPLICATE of bug 200009
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Per Arne Vollan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-07-22 13:17 PDT by Per Arne Vollan
Modified: 2019-07-22 14:33 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.48 KB, patch)
2019-07-22 13:32 PDT, Per Arne Vollan
pvollan: review?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Per Arne Vollan 2019-07-22 13:17:11 PDT
Remove denial of mach lookup to CoreMedia service in the WebContent process.
Comment 1 Per Arne Vollan 2019-07-22 13:17:40 PDT
rdar://problem/51565203
Comment 2 Brent Fulgham 2019-07-22 13:30:13 PDT
I think this might be a dupe of https://bugs.webkit.org/show_bug.cgi?id=200009.
Comment 3 Brent Fulgham 2019-07-22 13:30:35 PDT

*** This bug has been marked as a duplicate of bug 200009 ***
Comment 4 Per Arne Vollan 2019-07-22 13:32:15 PDT
Reopening to attach new patch.
Comment 5 Per Arne Vollan 2019-07-22 13:32:16 PDT
Created attachment 374624 [details]
Patch
Comment 6 Per Arne Vollan 2019-07-22 13:58:23 PDT

*** This bug has been marked as a duplicate of bug 20009 ***
Comment 7 mitz 2019-07-22 14:10:46 PDT
Did you mean bug 200009?
Comment 8 Alexey Proskuryakov 2019-07-22 14:25:44 PDT

*** This bug has been marked as a duplicate of bug 200009 ***
Comment 9 Per Arne Vollan 2019-07-22 14:33:44 PDT
(In reply to mitz from comment #7)
> Did you mean bug 200009?

Yes, thanks :)