Bug 199519 - [iOS] Local capture MediaStreamTrack does not render in portrait mode
Summary: [iOS] Local capture MediaStreamTrack does not render in portrait mode
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-07-05 09:16 PDT by youenn fablet
Modified: 2019-07-05 11:54 PDT (History)
5 users (show)

See Also:


Attachments
Patch (16.53 KB, patch)
2019-07-05 10:34 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (16.47 KB, patch)
2019-07-05 10:39 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2019-07-05 09:16:50 PDT
[iOS] Local capture MediaStreamTrack does not render locally in portrait mode
Rendering works fine in landscape mode.
Comment 1 youenn fablet 2019-07-05 09:16:56 PDT
This might be a regression due to https://trac.webkit.org/changeset/246644
Comment 2 Radar WebKit Bug Importer 2019-07-05 09:18:49 PDT
<rdar://problem/52689720>
Comment 3 Radar WebKit Bug Importer 2019-07-05 09:18:50 PDT
<rdar://problem/52689721>
Comment 4 youenn fablet 2019-07-05 10:34:09 PDT
Created attachment 373511 [details]
Patch
Comment 5 Build Bot 2019-07-05 10:38:41 PDT
Attachment 373511 [details] did not pass style-queue:


ERROR: Source/WebCore/platform/mock/MockRealtimeVideoSource.cpp:483:  A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]
Total errors found: 1 in 9 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 youenn fablet 2019-07-05 10:39:52 PDT
Created attachment 373512 [details]
Patch
Comment 7 WebKit Commit Bot 2019-07-05 11:54:20 PDT
Comment on attachment 373512 [details]
Patch

Clearing flags on attachment: 373512

Committed r247165: <https://trac.webkit.org/changeset/247165>
Comment 8 WebKit Commit Bot 2019-07-05 11:54:22 PDT
All reviewed patches have been landed.  Closing bug.