Bug 198834 - [iOS] Split up fast/events/ios/key-events-meta-alt-combinations.html and add more tests
Summary: [iOS] Split up fast/events/ios/key-events-meta-alt-combinations.html and add ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Local Build
Hardware: iPhone / iPad iOS 12
: P2 Normal
Assignee: Daniel Bates
URL:
Keywords: InRadar
Depends on: 198851
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-13 09:58 PDT by Daniel Bates
Modified: 2019-06-14 16:12 PDT (History)
4 users (show)

See Also:


Attachments
Patch (665.05 KB, patch)
2019-06-13 10:00 PDT, Daniel Bates
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews113 for mac-highsierra (3.04 MB, application/zip)
2019-06-13 11:45 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bates 2019-06-13 09:58:34 PDT
The test fast/events/ios/key-events-meta-alt-combinations.html frequently times out. Let's try to break up this test into multiple files. We should also more modifier combination tests.
Comment 1 Daniel Bates 2019-06-13 09:58:46 PDT
<rdar://problem/50103348>
Comment 2 Daniel Bates 2019-06-13 10:00:29 PDT
Created attachment 372061 [details]
Patch
Comment 3 Daniel Bates 2019-06-13 10:03:20 PDT
I should add that I also rebased the test result for key-events-meta.html now that we map Command + . to Escape following the fix in bug #198137. (We'll see if the bots agree with this change as I think it may require some UIKit bits as well)
Comment 4 Build Bot 2019-06-13 11:45:45 PDT
Comment on attachment 372061 [details]
Patch

Attachment 372061 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/12466494

New failing tests:
http/tests/media/video-error-abort.html
Comment 5 Build Bot 2019-06-13 11:45:47 PDT
Created attachment 372072 [details]
Archive of layout-test-results from ews113 for mac-highsierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews113  Port: mac-highsierra  Platform: Mac OS X 10.13.6
Comment 6 Daniel Bates 2019-06-13 16:02:36 PDT
Failure can't be caused by this page (famous last words™). I'm just adding more tests.
Comment 7 Daniel Bates 2019-06-13 16:03:33 PDT
(In reply to Daniel Bates from comment #6)
> Failure can't be caused by this page (famous last words™). I'm just adding
> more tests.

*patch
Comment 8 Brent Fulgham 2019-06-13 17:09:25 PDT
(In reply to Daniel Bates from comment #6)
> Failure can't be caused by this page (famous last words™). I'm just adding
> more tests.

Mac-debug doesn't pass before your patch, so its' not related.
Comment 9 Brent Fulgham 2019-06-13 17:10:11 PDT
Comment on attachment 372061 [details]
Patch

r=me. Hope this improves things!
Comment 10 Daniel Bates 2019-06-13 22:02:57 PDT
I am ***not*** going to land this patch until bug #198851 is resolved, a satisfactory answer is given, or I am demanded to land this patch.
Comment 11 Aakash Jain 2019-06-14 11:17:54 PDT
(In reply to Daniel Bates from comment #10)
> I am ***not*** going to land this patch until bug #198851 is resolved, a
> satisfactory answer is given, or I am demanded to land this patch.
EWS has processed this patch. Please feel free to land it.
Comment 12 Daniel Bates 2019-06-14 16:12:17 PDT
Comment on attachment 372061 [details]
Patch

Clearing flags on attachment: 372061

Committed r246450: <https://trac.webkit.org/changeset/246450>
Comment 13 Daniel Bates 2019-06-14 16:12:19 PDT
All reviewed patches have been landed.  Closing bug.