Bug 198607 - REGRESSION(r244857): [GTK][WPE] Many tests are no longer run in the bots after r244857
Summary: REGRESSION(r244857): [GTK][WPE] Many tests are no longer run in the bots afte...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2019-06-06 05:05 PDT by Carlos Garcia Campos
Modified: 2019-06-06 22:48 PDT (History)
6 users (show)

See Also:


Attachments
Patch (5.80 KB, patch)
2019-06-06 05:10 PDT, Carlos Garcia Campos
mcatanzaro: review+
ews-watchlist: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews106 for mac-highsierra-wk2 (3.15 MB, application/zip)
2019-06-06 06:25 PDT, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2019-06-06 05:05:15 PDT
Since r244857 several test executables are compiled in the base tests directory instead of using their own sub directory. Our scripts to run the tests rely on the tests location to decide whether to run them or not, or determine the type of the tests.
Comment 1 Carlos Garcia Campos 2019-06-06 05:10:17 PDT
Created attachment 371486 [details]
Patch
Comment 2 EWS Watchlist 2019-06-06 06:25:53 PDT
Comment on attachment 371486 [details]
Patch

Attachment 371486 [details] did not pass mac-wk2-ews (mac-wk2):
Output: https://webkit-queues.webkit.org/results/12394787

New failing tests:
http/wpt/service-workers/service-worker-networkprocess-crash.html
Comment 3 EWS Watchlist 2019-06-06 06:25:55 PDT
Created attachment 371491 [details]
Archive of layout-test-results from ews106 for mac-highsierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews106  Port: mac-highsierra-wk2  Platform: Mac OS X 10.13.6
Comment 4 Carlos Garcia Campos 2019-06-06 22:47:55 PDT
Committed r246189: <https://trac.webkit.org/changeset/246189>
Comment 5 Radar WebKit Bug Importer 2019-06-06 22:48:18 PDT
<rdar://problem/51512477>