Bug 197853 - [iOS] Crash when trying to QuickLook
Summary: [iOS] Crash when trying to QuickLook
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Per Arne Vollan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-05-13 14:14 PDT by Per Arne Vollan
Modified: 2019-05-13 14:48 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.35 KB, patch)
2019-05-13 14:16 PDT, Per Arne Vollan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Per Arne Vollan 2019-05-13 14:14:01 PDT
This is caused by a syscall sandbox violation.
Comment 1 Per Arne Vollan 2019-05-13 14:14:22 PDT
rdar://problem/49795964
Comment 2 Per Arne Vollan 2019-05-13 14:16:01 PDT
Created attachment 369781 [details]
Patch
Comment 3 Brent Fulgham 2019-05-13 14:16:37 PDT
Comment on attachment 369781 [details]
Patch

r=me
Comment 4 Per Arne Vollan 2019-05-13 14:21:06 PDT
Comment on attachment 369781 [details]
Patch

Thanks for reviewing!
Comment 5 WebKit Commit Bot 2019-05-13 14:48:15 PDT
Comment on attachment 369781 [details]
Patch

Clearing flags on attachment: 369781

Committed r245252: <https://trac.webkit.org/changeset/245252>
Comment 6 WebKit Commit Bot 2019-05-13 14:48:16 PDT
All reviewed patches have been landed.  Closing bug.