Bug 197675 - [macOS] Crash with sandbox error
Summary: [macOS] Crash with sandbox error
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Per Arne Vollan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-05-07 15:29 PDT by Per Arne Vollan
Modified: 2019-05-07 16:16 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.33 KB, patch)
2019-05-07 15:30 PDT, Per Arne Vollan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Per Arne Vollan 2019-05-07 15:29:06 PDT
This crash is caused by missing syscall rules in the sandbox.
Comment 1 Per Arne Vollan 2019-05-07 15:29:26 PDT
rdar://problem/50473330
Comment 2 Per Arne Vollan 2019-05-07 15:30:44 PDT
Created attachment 369331 [details]
Patch
Comment 3 Geoffrey Garen 2019-05-07 15:36:09 PDT
Comment on attachment 369331 [details]
Patch

r=me
Comment 4 Geoffrey Garen 2019-05-07 15:36:36 PDT
Can we catch this with a regression test?
Comment 5 Per Arne Vollan 2019-05-07 15:52:29 PDT
(In reply to Geoffrey Garen from comment #4)
> Can we catch this with a regression test?

Yes, I think this can be catched with a regression test, although reproduction steps are unknown at this point.

Thanks for reviewing!
Comment 6 WebKit Commit Bot 2019-05-07 16:16:44 PDT
Comment on attachment 369331 [details]
Patch

Clearing flags on attachment: 369331

Committed r245041: <https://trac.webkit.org/changeset/245041>
Comment 7 WebKit Commit Bot 2019-05-07 16:16:45 PDT
All reviewed patches have been landed.  Closing bug.