Bug 197408 - [Flatpak][Qt] Meson: Unknown type feature for gstreamer
Summary: [Flatpak][Qt] Meson: Unknown type feature for gstreamer
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-30 02:23 PDT by Ludovico de Nittis
Modified: 2019-05-20 07:50 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.72 KB, patch)
2019-04-30 02:31 PDT, Ludovico de Nittis
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovico de Nittis 2019-04-30 02:23:49 PDT
The flatpak build of WPE with the Qt extension enabled fails at compiling gstreamer 1.16.0 with the error "Unknown type feature".

This is due to the fact that "feature" was introduced with meson 0.47.0, but at build time meson 0.46.0 is used.

Steps to reproduce:
$ ./Tools/Scripts/webkit-flatpak --wpe --wpe-extension=qt --update


I'm going to submit a patch to fix it.
Comment 1 Ludovico de Nittis 2019-04-30 02:31:19 PDT
Created attachment 368545 [details]
Patch
Comment 2 Ludovico de Nittis 2019-04-30 04:55:37 PDT
Now I'm getting this error, not sure if it is related to the kde runtime 5.12 bump.
Comment 3 Ludovico de Nittis 2019-04-30 04:55:52 PDT
Forgot the link: https://paste.ubuntu.com/p/nvWmBjpq65/
Comment 4 Ludovico de Nittis 2019-04-30 08:10:18 PDT
The new error that I was receiving is not related to this patch. It's caused by another bug https://bugs.webkit.org/show_bug.cgi?id=197415
Comment 5 ews-feeder 2019-05-20 07:15:24 PDT
Comment on attachment 368545 [details]
Patch

Rejecting attachment 368545 [details] from commit-queue.

ludovico.denittis@collabora.com does not have committer permissions according to https://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/contributors.json.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/contributors.json by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 6 WebKit Commit Bot 2019-05-20 07:49:51 PDT
Comment on attachment 368545 [details]
Patch

Clearing flags on attachment: 368545

Committed r245515: <https://trac.webkit.org/changeset/245515>
Comment 7 WebKit Commit Bot 2019-05-20 07:49:53 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Radar WebKit Bug Importer 2019-05-20 07:50:20 PDT
<rdar://problem/50945849>