Bug 197144 - Regression(r243767) WebFrame::m_navigationIsContinuingInAnotherProcess flag is never reset
Summary: Regression(r243767) WebFrame::m_navigationIsContinuingInAnotherProcess flag i...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks: 196503
  Show dependency treegraph
 
Reported: 2019-04-20 21:45 PDT by Chris Dumez
Modified: 2019-04-21 13:15 PDT (History)
6 users (show)

See Also:


Attachments
Patch (8.61 KB, patch)
2019-04-20 22:41 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2019-04-20 21:45:48 PDT
WebFrame::m_navigationIsContinuingInAnotherProcess flag is never reset. This leads to leaking Navigation objects in the UIProcess when reusing a previously suspended process because such process will no longer send the DidDestroyNavigation IPC.
Comment 1 Chris Dumez 2019-04-20 22:41:22 PDT
Created attachment 367903 [details]
Patch
Comment 2 Chris Dumez 2019-04-21 13:14:08 PDT
Comment on attachment 367903 [details]
Patch

Clearing flags on attachment: 367903

Committed r244493: <https://trac.webkit.org/changeset/244493>
Comment 3 Chris Dumez 2019-04-21 13:14:10 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Radar WebKit Bug Importer 2019-04-21 13:15:18 PDT
<rdar://problem/50082236>