Bug 197057 - Tile update problems in iframe after scrolling page too soon after load
Summary: Tile update problems in iframe after scrolling page too soon after load
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-18 08:03 PDT by Antti Koivisto
Modified: 2019-04-18 09:32 PDT (History)
3 users (show)

See Also:


Attachments
patch (1.89 KB, patch)
2019-04-18 08:10 PDT, Antti Koivisto
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2019-04-18 08:03:15 PDT
Summary:
Tile update problems in iframe after scrolling page to quickly after load

Steps To Reproduce:
1. https://www.bloomberg.com/graphics/2018-tesla-tracker/
2. Scroll down to Tesla Production Blog section
3. Scroll the blog iframe

Results:
If you started scrolling the main page immediately after the page load to get to the blog, the iframe doesn’t generate tiles when scrolling. There is a main page scrolling jump soon after the load completes which may be related (some viewport update thing?)

If you simply wait a bit after the page load without scrolling anything, the iframe scrolling works fine too later. Waiting until Reader availability text goes away is sufficient.
Comment 1 Antti Koivisto 2019-04-18 08:06:28 PDT
<rdar://problem/49913663>
Comment 2 Antti Koivisto 2019-04-18 08:10:32 PDT
Created attachment 367728 [details]
patch
Comment 3 WebKit Commit Bot 2019-04-18 09:32:04 PDT
Comment on attachment 367728 [details]
patch

Clearing flags on attachment: 367728

Committed r244426: <https://trac.webkit.org/changeset/244426>
Comment 4 WebKit Commit Bot 2019-04-18 09:32:05 PDT
All reviewed patches have been landed.  Closing bug.