Bug 196950 - Base HREF breaks SVG resources (gradients, patterns and filters)
Summary: Base HREF breaks SVG resources (gradients, patterns and filters)
Status: RESOLVED DUPLICATE of bug 189499
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-15 17:48 PDT by Said Abou-Hallawa
Modified: 2019-05-06 15:26 PDT (History)
2 users (show)

See Also:


Attachments
test case (788 bytes, text/html)
2019-04-15 17:48 PDT, Said Abou-Hallawa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Said Abou-Hallawa 2019-04-15 17:48:03 PDT
Created attachment 367482 [details]
test case

Open the attached test case.

Expected: Three rectangles filled with green.
Actual results: Two rectangles filled with black.

The first rectangle is filled using a gradient resource. The second rectangle is filled with a pattern resource. And the third rectangle is a <use> element referencing a filter resource.

Because the page has the tag <base href="/">, all the links to the resources are broken.
Comment 1 Said Abou-Hallawa 2019-04-15 17:48:46 PDT
<rdar://problem/49215320>
Comment 2 Said Abou-Hallawa 2019-05-06 15:26:02 PDT

*** This bug has been marked as a duplicate of bug 189499 ***