Bug 19648 - Should the dropdown list be skipped in tab navigation?
Summary: Should the dropdown list be skipped in tab navigation?
Status: VERIFIED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P2 Trivial
Assignee: Nobody
URL: https://bugzilla.mozilla.org/show_bug...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-17 23:01 PDT by Tom
Modified: 2008-06-17 23:21 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2008-06-17 23:01:48 PDT
There is a bit of debate over if it's a bug in safari or not for safari to allow you to tab navigate to dropdown menus.

I'll include some select quotes:

(In reply to comment #6)
> (In reply to comment #5)
> > It's interesting (and perhaps a Safari bug) that Safari does this, because
> > popup menus elsewhere in the OS definitely don't get focused when FKA is off. 
> 
> Apple seems not to think it's a bug, since Safari 3 (along with all WebKit
> browsers) continues this practice.  I still think it's odd, though, since it
> doesn't match the rest of the OS.  That, or hyatt hasn't figured out how to
> differentiate between select-as-popup-menu and select-as-listbox yet, which I
> find improbable ;)

So, should Safari do this, or is it a bug?
Comment 1 Dave Hyatt 2008-06-17 23:06:33 PDT
It's not a bug.  We do this on purpose for compatibility.

Comment 2 Dave Hyatt 2008-06-17 23:07:31 PDT
We make an exception for the dropdown list even though it does not match the OS, since it just makes it easier to fill out forms from the keyboard without having to turn on full keyboard access.