Bug 195617 - Flaky Test: legacy-animation-engine/cssom/cssvalue-comparison.html
Summary: Flaky Test: legacy-animation-engine/cssom/cssvalue-comparison.html
Status: RESOLVED DUPLICATE of bug 195431
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2019-03-12 04:38 PDT by WebKit Commit Bot
Modified: 2019-03-13 17:16 PDT (History)
5 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-03 (2.48 MB, application/zip)
2019-03-12 04:38 PDT, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2019-03-12 04:38:15 PDT
This is an automatically generated bug from the commit-queue.
legacy-animation-engine/cssom/cssvalue-comparison.html has been flaky on the commit-queue.

legacy-animation-engine/cssom/cssvalue-comparison.html was authored by dino@apple.com and graouts@apple.com.
https://trac.webkit.org/browser/trunk/LayoutTests/legacy-animation-engine/cssom/cssvalue-comparison.html

The commit-queue just saw legacy-animation-engine/cssom/cssvalue-comparison.html flake (DumpRenderTree crashed) while processing attachment 364376 [details] on bug 195610.
Bot: webkit-cq-03  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.13.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2019-03-12 04:38:16 PDT
Created attachment 364378 [details]
Archive of layout-test-results from webkit-cq-03
Comment 2 Ryan Haddad 2019-03-12 12:06:21 PDT
Application Specific Information:
CRASHING TEST: legacy-animation-engine/cssom/cssvalue-comparison.html

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   ???                           	000000000000000000 0 + 0
1   com.apple.WebCore             	0x000000010fd1cd5d WebCore::CanvasBase::notifyObserversCanvasDestroyed() + 109 (HashTable.h:182)
2   com.apple.WebCore             	0x000000010fd46c7e WebCore::HTMLCanvasElement::~HTMLCanvasElement() + 46 (memory:2595)
3   com.apple.WebCore             	0x000000010fd46dff WebCore::HTMLCanvasElement::~HTMLCanvasElement() + 15
4   com.apple.JavaScriptCore      	0x000000010c6de63d void JSC::MarkedBlock::Handle::specializedSweep<true, (JSC::MarkedBlock::Handle::EmptyMode)1, (JSC::MarkedBlock::Handle::SweepMode)1, (JSC::MarkedBlock::Handle::SweepDestructionMode)1, (JSC::MarkedBlock::Handle::ScribbleMode)0, (JSC::MarkedBlock::Handle::NewlyAllocatedMode)1, (JSC::MarkedBlock::Handle::MarksMode)1, JSC::JSDestructibleObjectDestroyFunc>(JSC::FreeList*, JSC::MarkedBlock::Handle::EmptyMode, JSC::MarkedBlock::Handle::SweepMode, JSC::MarkedBlock::Handle::SweepDestructionMode, JSC::MarkedBlock::Handle::ScribbleMode, JSC::MarkedBlock::Handle::NewlyAllocatedMode, JSC::MarkedBlock::Handle::MarksMode, JSC::JSDestructibleObjectDestroyFunc const&) + 173 (JSDestructibleObjectHeapCellType.cpp:37)
5   com.apple.JavaScriptCore      	0x000000010c6dd030 void JSC::MarkedBlock::Handle::finishSweepKnowingHeapCellType<JSC::JSDestructibleObjectDestroyFunc>(JSC::FreeList*, JSC::JSDestructibleObjectDestroyFunc const&)::'lambda'()::operator()() const + 384
6   com.apple.JavaScriptCore      	0x000000010c6dc9d3 void JSC::MarkedBlock::Handle::finishSweepKnowingHeapCellType<JSC::JSDestructibleObjectDestroyFunc>(JSC::FreeList*, JSC::JSDestructibleObjectDestroyFunc const&) + 307 (MarkedBlockInlines.h:435)
7   com.apple.JavaScriptCore      	0x000000010c6dc89a JSC::JSDestructibleObjectHeapCellType::finishSweep(JSC::MarkedBlock::Handle&, JSC::FreeList*) + 26 (JSDestructibleObjectHeapCellType.cpp:53)
8   com.apple.JavaScriptCore      	0x000000010c339224 JSC::MarkedBlock::Handle::sweep(JSC::FreeList*) + 308
Comment 3 Ryan Haddad 2019-03-13 17:16:47 PDT

*** This bug has been marked as a duplicate of bug 195431 ***