Bug 195579 - A lot more classes have padding that can be reduced by reordering their fields
Summary: A lot more classes have padding that can be reduced by reordering their fields
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Trivial
Assignee: Robin Morisset
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-03-11 16:44 PDT by Robin Morisset
Modified: 2019-03-12 12:08 PDT (History)
11 users (show)

See Also:


Attachments
Patch (30.37 KB, patch)
2019-03-11 16:49 PDT, Robin Morisset
no flags Details | Formatted Diff | Diff
Patch (31.00 KB, patch)
2019-03-11 18:04 PDT, Robin Morisset
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews122 for ios-simulator-wk2 (2.48 MB, application/zip)
2019-03-11 23:36 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Morisset 2019-03-11 16:44:10 PDT
Just a bunch more in the same style as the ones I committed on Friday.
Comment 1 Robin Morisset 2019-03-11 16:49:24 PDT
Created attachment 364309 [details]
Patch
Comment 2 Build Bot 2019-03-11 16:53:04 PDT
Attachment 364309 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/dfg/DFGPlan.cpp:139:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGPlan.cpp:140:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGPlan.cpp:144:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGSlowPathGenerator.h:115:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGArrayifySlowPathGenerator.h:47:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGCallArrayAllocatorSlowPathGenerator.h:46:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGCallArrayAllocatorSlowPathGenerator.h:84:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
Total errors found: 7 in 35 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Mark Lam 2019-03-11 17:05:26 PDT
Comment on attachment 364309 [details]
Patch

r=me if EWS shows no regression.
Comment 4 Robin Morisset 2019-03-11 18:04:49 PDT
Created attachment 364326 [details]
Patch
Comment 5 Build Bot 2019-03-11 18:07:18 PDT
Attachment 364326 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/dfg/DFGPlan.cpp:139:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGPlan.cpp:140:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGPlan.cpp:144:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGSlowPathGenerator.h:115:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGArrayifySlowPathGenerator.h:47:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGCallArrayAllocatorSlowPathGenerator.h:46:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/dfg/DFGCallArrayAllocatorSlowPathGenerator.h:84:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
Total errors found: 7 in 35 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Build Bot 2019-03-11 23:36:24 PDT
Comment on attachment 364326 [details]
Patch

Attachment 364326 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/11467979

New failing tests:
fast/events/change-overflow-on-overflow-change.html
Comment 7 Build Bot 2019-03-11 23:36:27 PDT
Created attachment 364357 [details]
Archive of layout-test-results from ews122 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews122  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 8 Robin Morisset 2019-03-12 11:39:49 PDT
Comment on attachment 364326 [details]
Patch

This failure of EWS looks like flakiness of the tests considering that both jsc and Mac-debug are green.
Comment 9 WebKit Commit Bot 2019-03-12 12:07:10 PDT
Comment on attachment 364326 [details]
Patch

Clearing flags on attachment: 364326

Committed r242812: <https://trac.webkit.org/changeset/242812>
Comment 10 WebKit Commit Bot 2019-03-12 12:07:12 PDT
All reviewed patches have been landed.  Closing bug.
Comment 11 Radar WebKit Bug Importer 2019-03-12 12:08:36 PDT
<rdar://problem/48817827>