Bug 195183 - In cloop.rb, rename :int and :uint to :intptr and :uintptr.
Summary: In cloop.rb, rename :int and :uint to :intptr and :uintptr.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-02-28 12:46 PST by Mark Lam
Modified: 2019-02-28 16:05 PST (History)
7 users (show)

See Also:


Attachments
proposed patch. (24.94 KB, patch)
2019-02-28 14:29 PST, Mark Lam
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2019-02-28 12:46:17 PST
It would be less confusing to match their C++ type names.
Comment 1 Mark Lam 2019-02-28 14:29:27 PST
Created attachment 363261 [details]
proposed patch.
Comment 2 Yusuke Suzuki 2019-02-28 14:32:12 PST
Comment on attachment 363261 [details]
proposed patch.

r=me
Comment 3 Mark Lam 2019-02-28 15:43:16 PST
Comment on attachment 363261 [details]
proposed patch.

Thanks for the review.  Landing now.
Comment 4 WebKit Commit Bot 2019-02-28 16:04:56 PST
Comment on attachment 363261 [details]
proposed patch.

Clearing flags on attachment: 363261

Committed r242240: <https://trac.webkit.org/changeset/242240>
Comment 5 WebKit Commit Bot 2019-02-28 16:04:58 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Radar WebKit Bug Importer 2019-02-28 16:05:33 PST
<rdar://problem/48492852>