Bug 19475 - Real Player 11 plug-in disappears after opening and closing page containing Real Player plug-in
Summary: Real Player 11 plug-in disappears after opening and closing page containing R...
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Major
Assignee: Nobody
URL: http://www.mozilla.org/quality/browse...
Keywords: InRadar, PlatformOnly
Depends on:
Blocks:
 
Reported: 2008-06-10 22:42 PDT by Robert Blaut
Modified: 2008-06-11 00:30 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Blaut 2008-06-10 22:42:27 PDT
I've noticed that Real Player 11 plug-in incorrectly works with Safari/Webkit. After opening Safari and example page rendering Real Player 11 plug-in for the first time the plug-in runs without problem. But if you close that page and you open the page again or open other page containing the plug-in the plug-in fails to render in Safari. You have to restart browser as workaround for the bug, but it only works once.

The issue is only visible on Windows platform.

Steps to reproduce:
0) Install Real Player 11 for Windows from www.real.com.
1) Go to a page: http://www.mozilla.org/quality/browser/front-end/testcases/plugins/ra3.html
2) Close the page.
3) Open the page again or open other page like: http://www.mozilla.org/quality/browser/front-end/testcases/plugins/ra4.html

Expected behavior:
Real Player 11 plug-in should be rendered on the page.

Current behavior:
Real Player 11 plug-in fails to render on the page.
Comment 1 Mark Rowe (bdash) 2008-06-11 00:30:36 PDT
<rdar://problem/5999638>