Bug 193965 - EnableResizeObserver for ResizeObserver test cases when webkit-test-runner
Summary: EnableResizeObserver for ResizeObserver test cases when webkit-test-runner
Status: RESOLVED DUPLICATE of bug 157743
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: cathiechen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-29 08:11 PST by cathiechen
Modified: 2019-03-29 01:22 PDT (History)
3 users (show)

See Also:


Attachments
Patch (4.42 KB, patch)
2019-01-29 08:33 PST, cathiechen
no flags Details | Formatted Diff | Diff
Patch (5.91 KB, patch)
2019-03-28 10:03 PDT, cathiechen
no flags Details | Formatted Diff | Diff
Patch (5.91 KB, patch)
2019-03-28 10:06 PDT, cathiechen
no flags Details | Formatted Diff | Diff
Patch (5.91 KB, patch)
2019-03-28 17:22 PDT, cathiechen
no flags Details | Formatted Diff | Diff
To test building error in wincairo (156.82 KB, patch)
2019-03-28 20:35 PDT, cathiechen
no flags Details | Formatted Diff | Diff
To test wincairo build error (148.96 KB, patch)
2019-03-28 21:46 PDT, cathiechen
no flags Details | Formatted Diff | Diff
To test wincairo build error (148.96 KB, patch)
2019-03-28 21:53 PDT, cathiechen
no flags Details | Formatted Diff | Diff
To test wincairo build error (50.38 KB, patch)
2019-03-28 22:14 PDT, cathiechen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description cathiechen 2019-01-29 08:11:33 PST
EnableResizeObserver for ResizeObserver test cases  when webkit-test-runner
Comment 1 cathiechen 2019-01-29 08:33:19 PST
Created attachment 360461 [details]
Patch
Comment 2 Frédéric Wang (:fredw) 2019-01-30 00:26:27 PST
Comment on attachment 360461 [details]
Patch

I think this should be done when you first introduce the ResizeObserver preference (i.e. for now in your patch for bug 157743).
Comment 3 cathiechen 2019-01-30 05:37:47 PST
(In reply to Frédéric Wang (:fredw) from comment #2)
> Comment on attachment 360461 [details]
> Patch
> 
> I think this should be done when you first introduce the ResizeObserver
> preference (i.e. for now in your patch for bug 157743).

OK, got it. Thanks:)
Comment 4 cathiechen 2019-03-28 10:03:10 PDT
Created attachment 366181 [details]
Patch
Comment 5 cathiechen 2019-03-28 10:06:14 PDT
Created attachment 366182 [details]
Patch
Comment 6 cathiechen 2019-03-28 17:22:51 PDT
Created attachment 366227 [details]
Patch
Comment 7 cathiechen 2019-03-28 20:35:01 PDT
Created attachment 366240 [details]
To test building error in wincairo
Comment 8 cathiechen 2019-03-28 21:46:17 PDT
Created attachment 366246 [details]
To test wincairo build error
Comment 9 cathiechen 2019-03-28 21:53:22 PDT
Created attachment 366247 [details]
To test wincairo build error
Comment 10 Build Bot 2019-03-28 21:55:05 PDT
Attachment 366247 [details] did not pass style-queue:


ERROR: Source/WebCore/PAL/Configurations/FeatureDefines.xcconfig:0:  Any changes made to FeatureDefines should be made to all of them (changed file does not match Tools/TestWebKitAPI/Configurations/FeatureDefines.xcconfig). Use sync-feature-defines if possible.  [featuredefines/equality] [5]
ERROR: Source/WebCore/Configurations/FeatureDefines.xcconfig:0:  Any changes made to FeatureDefines should be made to all of them (changed file does not match Tools/TestWebKitAPI/Configurations/FeatureDefines.xcconfig). Use sync-feature-defines if possible.  [featuredefines/equality] [5]
ERROR: Source/WebKit/Configurations/FeatureDefines.xcconfig:0:  Any changes made to FeatureDefines should be made to all of them (changed file does not match Tools/TestWebKitAPI/Configurations/FeatureDefines.xcconfig). Use sync-feature-defines if possible.  [featuredefines/equality] [5]
ERROR: Source/JavaScriptCore/Configurations/FeatureDefines.xcconfig:0:  Any changes made to FeatureDefines should be made to all of them (changed file does not match Tools/TestWebKitAPI/Configurations/FeatureDefines.xcconfig). Use sync-feature-defines if possible.  [featuredefines/equality] [5]
ERROR: Source/WebKitLegacy/mac/Configurations/FeatureDefines.xcconfig:0:  Any changes made to FeatureDefines should be made to all of them (changed file does not match Tools/TestWebKitAPI/Configurations/FeatureDefines.xcconfig). Use sync-feature-defines if possible.  [featuredefines/equality] [5]
Total errors found: 5 in 81 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 11 cathiechen 2019-03-28 22:14:17 PDT
Created attachment 366249 [details]
To test wincairo build error
Comment 12 cathiechen 2019-03-29 01:22:11 PDT
This has been resolved in bug 157743.

*** This bug has been marked as a duplicate of bug 157743 ***