Bug 19244 - REGRESSION (r28505-r28565): caret dissapears in rtl ContentEditable
Summary: REGRESSION (r28505-r28565): caret dissapears in rtl ContentEditable
Status: RESOLVED DUPLICATE of bug 19086
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: GoogleBug, HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2008-05-25 07:47 PDT by Shoshannah Forbes
Modified: 2008-05-25 10:15 PDT (History)
3 users (show)

See Also:


Attachments
Testcase (622 bytes, text/html)
2008-05-25 07:47 PDT, Shoshannah Forbes
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shoshannah Forbes 2008-05-25 07:47:01 PDT
in an RTL ContentEditable form, moving up/down using the arrow keys causes the caret to go blank.

This is a regression from Safari 3.1


To repro:
1) open attached test case
2) click somewhere in the form.
3) move up and down using the arrow keys

actual result
the caret is gone when inside the RTL block
Comment 1 Shoshannah Forbes 2008-05-25 07:47:47 PDT
Created attachment 21335 [details]
Testcase
Comment 2 Mark Grossmann 2008-05-25 08:11:10 PDT
Actually a regression from 3.0.3.
Safari 3.1.1 and nightly are affected.
Comment 3 David Kilzer (:ddkilzer) 2008-05-25 09:23:56 PDT
<rdar://problem/5962254>
Comment 4 David Kilzer (:ddkilzer) 2008-05-25 09:46:43 PDT
The bisect-builds script says:

Works: r28505  Fails: r28565
Comment 5 mitz 2008-05-25 10:15:05 PDT

*** This bug has been marked as a duplicate of 19086 ***