Bug 192052 - Flaky Test: imported/w3c/web-platform-tests/encoding/legacy-mb-tchinese/big5/big5-encode-form-errors-hangul.html
Summary: Flaky Test: imported/w3c/web-platform-tests/encoding/legacy-mb-tchinese/big5/...
Status: RESOLVED DUPLICATE of bug 192050
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2018-11-27 16:27 PST by WebKit Commit Bot
Modified: 2018-12-01 16:06 PST (History)
4 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-02 (2.54 MB, application/zip)
2018-11-27 16:27 PST, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2018-11-27 16:27:18 PST
This is an automatically generated bug from the commit-queue.
imported/w3c/web-platform-tests/encoding/legacy-mb-tchinese/big5/big5-encode-form-errors-hangul.html has been flaky on the commit-queue.

imported/w3c/web-platform-tests/encoding/legacy-mb-tchinese/big5/big5-encode-form-errors-hangul.html was authored by mjs@apple.com.
https://trac.webkit.org/browser/trunk/LayoutTests/imported/w3c/web-platform-tests/encoding/legacy-mb-tchinese/big5/big5-encode-form-errors-hangul.html

The commit-queue just saw imported/w3c/web-platform-tests/encoding/legacy-mb-tchinese/big5/big5-encode-form-errors-hangul.html flake (DumpRenderTree crashed) while processing attachment 355790 [details] on bug 191984.
Bot: webkit-cq-02  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-11-27 16:27:19 PST
Created attachment 355810 [details]
Archive of layout-test-results from webkit-cq-02
Comment 2 Alexey Proskuryakov 2018-11-28 09:54:08 PST
Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.JavaScriptCore      	0x0000000108534c55 JSC::speculationFromValue(JSC::JSValue) + 213 (SpeculatedType.cpp:477)
1   com.apple.JavaScriptCore      	0x00000001085067f6 JSC::CodeBlock::updateAllPredictionsAndCountLiveness(unsigned int&, unsigned int&) + 1814 (SpeculatedType.h:473)
2   com.apple.JavaScriptCore      	0x0000000108501466 JSC::CodeBlock::updateAllPredictions() + 22 (CodeBlock.cpp:2624)
3   com.apple.JavaScriptCore      	0x0000000108903dfc operationOptimize + 348 (JITOperations.cpp:1422)
Comment 3 Alexey Proskuryakov 2018-12-01 16:06:16 PST

*** This bug has been marked as a duplicate of bug 192050 ***