Bug 19124 - position: absolute handled incorrectly when text-align: right applied to parent element
Summary: position: absolute handled incorrectly when text-align: right applied to pare...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://vitaly.harisov.name/bugs/webki...
Keywords:
: 29781 (view as bug list)
Depends on: 47148
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 01:12 PDT by Vitaly Harisov
Modified: 2013-01-29 12:35 PST (History)
5 users (show)

See Also:


Attachments
Screenshot: WebKit-SVN-r33561, Opera 9.5 beta 2, Firefox 2.0.0.11 (85.98 KB, image/png)
2008-05-19 01:14 PDT, Vitaly Harisov
no flags Details
Shows incorrect handling of position absolute with a parent element having direction rtl. (465 bytes, text/html)
2011-06-16 14:32 PDT, Robert Flack
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitaly Harisov 2008-05-19 01:12:57 PDT
See example.
Comment 1 Vitaly Harisov 2008-05-19 01:14:09 PDT
Created attachment 21226 [details]
Screenshot: WebKit-SVN-r33561, Opera 9.5 beta 2, Firefox 2.0.0.11
Comment 2 mitz 2009-09-27 17:11:37 PDT
*** Bug 29781 has been marked as a duplicate of this bug. ***
Comment 3 Robert Flack 2011-06-16 14:32:20 PDT
Created attachment 97500 [details]
Shows incorrect handling of position absolute with a parent element having direction rtl.

Demonstrates that position absolute is handled incorrectly within direction rtl elements as well. Both red boxes should be inside and right aligned within the black outlined container.
Comment 4 Gérard Talbot 2011-07-16 22:26:57 PDT
Semi-reduced testcase:
http://www.gtalbot.org/BrowserBugsSection/Konqueror4Bugs/Bug147690-Uranio.html

Reduced testcase:
http://www.gtalbot.org/BrowserBugsSection/Konqueror4Bugs/Bug147690-Uranio-2.html

Firefox 5.0, Opera 11.50 and Konqueror 4.6.5 (KHTML engine) render those
testcases the same. Chrome 12.0.742.124 renders those testcases differently.

I sincerly am not sure which browsers is correct in rendering those testcases.
What Chrome 12.0.742.124 makes sense in my mind.

KDE Platform Version: 4.6.5
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic-pae i686
Distribution: Kubuntu 11.04
here.

-----------


Correspondent bug report at bugs.kde.org
_bug 147690_ : [testcase] Problems with CSS Absolute Positioned Elements
https://bugs.kde.org/show_bug.cgi?id=147690

regards, Gérard
Comment 5 Robert Hogan 2011-08-02 14:45:11 PDT
The test case works fine against the patch at 47148.
Comment 6 Robert Hogan 2013-01-29 12:35:04 PST
This is resolved now.