Bug 190072 - Web Inspector: image resources without content are still shown when the Images folder is selected
Summary: Web Inspector: image resources without content are still shown when the Image...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-09-27 23:42 PDT by Devin Rousso
Modified: 2018-09-28 01:05 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.55 KB, patch)
2018-09-27 23:44 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2018-09-27 23:42:55 PDT
In inspector2, clicking on the "Images" folder will show the list of images used by WebInspector.  Since we use a lot of SVG fragment images, these won't display properly.  As a result, a large "Resource has no content" over the entire content area, making it impossible to see any other images.  We should remove the image's `WI.ImageResourceContentView` if it has no content, just like how we remove it if there's an error.
Comment 1 Devin Rousso 2018-09-27 23:44:29 PDT
Created attachment 351059 [details]
Patch
Comment 2 Matt Baker 2018-09-28 00:31:44 PDT
I tried to repro this and was able to view some images and not others. Steps to reproduce or screenshots would be help to clarify and illustrate the problem.
Comment 3 Matt Baker 2018-09-28 00:37:18 PDT
(In reply to Matt Baker from comment #2)
> I tried to repro this and was able to view some images and not others. Steps
> to reproduce or screenshots would be help to clarify and illustrate the
> problem.

Disregard, I misread the bug description.
Comment 4 Matt Baker 2018-09-28 00:38:13 PDT
Comment on attachment 351059 [details]
Patch

r=me
Comment 5 WebKit Commit Bot 2018-09-28 01:04:17 PDT
Comment on attachment 351059 [details]
Patch

Clearing flags on attachment: 351059

Committed r236596: <https://trac.webkit.org/changeset/236596>
Comment 6 WebKit Commit Bot 2018-09-28 01:04:19 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Radar WebKit Bug Importer 2018-09-28 01:05:42 PDT
<rdar://problem/44857443>