Bug 188819 - Web Inspector: REGRESSION: InspectorStyleSheet not visible in the resources sidebar
Summary: Web Inspector: REGRESSION: InspectorStyleSheet not visible in the resources s...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
: 183069 (view as bug list)
Depends on: 138810
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-21 14:55 PDT by Devin Rousso
Modified: 2018-09-21 14:57 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.73 KB, patch)
2018-08-21 15:20 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2018-08-21 14:55:50 PDT
STEPS TO REPRODUCE:
1. Open any page to Elements
2. Add a new rule in the CSS Rules sidebar
3. Click on the "Inspector Style Sheet:1" link in the newly created CSS rule
 => No resource is selected/visible for the InspectorStyleSheet in the NavigationSidebar

NOTES:
Not sure when this regressed, but it has to be after r217258 <https://webkit.org/b/138810> as that's when it was added.
Comment 1 Radar WebKit Bug Importer 2018-08-21 14:57:17 PDT
<rdar://problem/43579039>
Comment 2 Devin Rousso 2018-08-21 15:20:23 PDT
Created attachment 347710 [details]
Patch
Comment 3 Brian Burg 2018-08-23 13:01:10 PDT
Comment on attachment 347710 [details]
Patch

r=me
Comment 4 WebKit Commit Bot 2018-08-23 13:06:23 PDT
Comment on attachment 347710 [details]
Patch

Clearing flags on attachment: 347710

Committed r235240: <https://trac.webkit.org/changeset/235240>
Comment 5 WebKit Commit Bot 2018-08-23 13:06:24 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Devin Rousso 2018-09-21 14:57:54 PDT
*** Bug 183069 has been marked as a duplicate of this bug. ***