Bug 18657 - Associating style sheets with XML documents does not respect media types
Summary: Associating style sheets with XML documents does not respect media types
Status: RESOLVED DUPLICATE of bug 11939
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2008-04-21 09:02 PDT by Frank Illenberger
Modified: 2018-06-15 21:50 PDT (History)
3 users (show)

See Also:


Attachments
Testcase demonstrating the problem. (2.64 KB, application/octet-stream)
2008-04-21 09:03 PDT, Frank Illenberger
no flags Details
First attempt (5.10 KB, patch)
2008-04-26 03:04 PDT, Rob Buis
rwlbuis: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Illenberger 2008-04-21 09:02:23 PDT
When a style sheet is associated with an XML document via

<?xml-stylesheet type="text/css" href="print.css" media="print"?>

the media attribute is not respected and the contents of the sheet is used for the styling of screen content.

The media attribute should be respected with the same semantics as in HTML documents.
Firefox and Opera do not show this problem.
Comment 1 Frank Illenberger 2008-04-21 09:03:02 PDT
Created attachment 20726 [details]
Testcase demonstrating the problem.
Comment 2 Rob Buis 2008-04-26 03:04:19 PDT
Created attachment 20829 [details]
First attempt

Media transfer was simply lacking :)
Cheers,

Rob.
Comment 3 Maciej Stachowiak 2008-04-26 14:22:17 PDT
The test should probably check that "change" is sent after "input".
Comment 4 David Kilzer (:ddkilzer) 2008-04-26 15:07:55 PDT
Confirmed as duplicate of Bug 11939.

Comment 5 David Kilzer (:ddkilzer) 2008-04-26 15:08:39 PDT
Please duplicate to Bug 11939 when fixed!

Comment 6 David Kilzer (:ddkilzer) 2008-04-26 15:09:14 PDT
(In reply to comment #5)
> Please duplicate to Bug 11939 when fixed!

I don't want to mark it as a duplicate now since I don't want Rob's patch to be "lost".

Comment 7 Rob Buis 2008-04-27 00:13:05 PDT

*** This bug has been marked as a duplicate of 11939 ***