Bug 185842 - REGRESSION(r231998): causes crashes on 32 JSC bot (Requested by realdawei on #webkit).
Summary: REGRESSION(r231998): causes crashes on 32 JSC bot (Requested by realdawei on ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords: InRadar
Depends on:
Blocks: 185682
  Show dependency treegraph
 
Reported: 2018-05-21 14:49 PDT by WebKit Commit Bot
Modified: 2018-05-22 19:05 PDT (History)
7 users (show)

See Also:


Attachments
ROLLOUT of r231998 (85.26 KB, patch)
2018-05-21 14:49 PDT, WebKit Commit Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2018-05-21 14:49:08 PDT
https://trac.webkit.org/changeset/231998 broke the build:
causes crashes on 32 JSC bot (Requested by realdawei on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2018-05-21 14:49:34 PDT
Created attachment 340898 [details]
ROLLOUT of r231998

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Commit Bot 2018-05-21 14:52:32 PDT
Comment on attachment 340898 [details]
ROLLOUT of r231998

Clearing flags on attachment: 340898

Committed r232029: <https://trac.webkit.org/changeset/232029>
Comment 3 Filip Pizlo 2018-05-21 14:52:32 PDT
What is this 32-bit bot?
Comment 4 WebKit Commit Bot 2018-05-21 14:52:34 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Radar WebKit Bug Importer 2018-05-21 14:53:24 PDT
<rdar://problem/40430750>
Comment 6 Dominik Inführ 2018-05-21 15:15:29 PDT
Here is the patch that make this change work on 32-bit architectures: https://bugs.webkit.org/show_bug.cgi?id=185845.
Comment 7 Alexey Proskuryakov 2018-05-22 19:05:17 PDT
> What is this 32-bit bot?

I'm guessing this one:

https://build.webkit.org/builders/Apple%20High%20Sierra%2032-bit%20JSC%20(BuildAndTest)?numbuilds=50