Bug 185603 - REGRESSION(r219515): It sometimes makes AudioUnitInitialize call to fail in CoreAudioCaptureSource (Requested by youenn on #webkit).
Summary: REGRESSION(r219515): It sometimes makes AudioUnitInitialize call to fail in C...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords: InRadar
Depends on:
Blocks: 174512
  Show dependency treegraph
 
Reported: 2018-05-14 00:31 PDT by WebKit Commit Bot
Modified: 2018-05-14 00:34 PDT (History)
3 users (show)

See Also:


Attachments
ROLLOUT of r219515 (1.57 KB, patch)
2018-05-14 00:31 PDT, WebKit Commit Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2018-05-14 00:31:23 PDT
https://trac.webkit.org/changeset/219515 broke the build:
It sometimes makes AudioUnitInitialize call to fail in CoreAudioCaptureSource (Requested by youenn on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2018-05-14 00:31:28 PDT
Created attachment 340297 [details]
ROLLOUT of r219515

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Commit Bot 2018-05-14 00:34:00 PDT
Comment on attachment 340297 [details]
ROLLOUT of r219515

Clearing flags on attachment: 340297

Committed r231749: <https://trac.webkit.org/changeset/231749>
Comment 3 WebKit Commit Bot 2018-05-14 00:34:02 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Radar WebKit Bug Importer 2018-05-14 00:34:16 PDT
<rdar://problem/40210005>