Bug 184061 - REGRESSION (r229831?): Layout Test http/tests/appcache/interrupted-update.html is a flaky failure
Summary: REGRESSION (r229831?): Layout Test http/tests/appcache/interrupted-update.htm...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-03-27 17:12 PDT by Ryan Haddad
Modified: 2018-05-17 13:40 PDT (History)
9 users (show)

See Also:


Attachments
Patch (5.41 KB, patch)
2018-05-09 04:20 PDT, youenn fablet
ews-watchlist: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-sierra (2.21 MB, application/zip)
2018-05-09 05:25 PDT, EWS Watchlist
no flags Details
Archive of layout-test-results from ews107 for mac-sierra-wk2 (2.79 MB, application/zip)
2018-05-09 05:30 PDT, EWS Watchlist
no flags Details
Patch (6.38 KB, patch)
2018-05-09 10:39 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-03-27 17:12:53 PDT
The following layout test is flaky on iOS and macOS

http/tests/appcache/interrupted-update.html

Probable cause:

Unknown, this test became flaky within the last 7 days. The earliest failure seen on the dashboard for macOS blames https://trac.webkit.org/log/webkit/?verbose=on&rev=229746&stop_rev=229746

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2Fappcache%2Finterrupted-update.html
Comment 1 Alexey Proskuryakov 2018-03-28 15:42:26 PDT
@@ -1,3 +1,5 @@
+CONSOLE MESSAGE: line 1: ApplicationCache is deprecated. Please use ServiceWorkers instead.
+CONSOLE MESSAGE: line 37: Reloading...
 CONSOLE MESSAGE: line 1: ApplicationCache is deprecated. Please use ServiceWorkers instead.
 CONSOLE MESSAGE: line 37: Reloading...
 CONSOLE MESSAGE: line 1: ApplicationCache is deprecated. Please use ServiceWorkers instead.


There was a new test added in r229733 (http/tests/appcache/document-cookie.php), I wonder if this is somehow caused by it.
Comment 2 Alexey Proskuryakov 2018-03-28 15:44:51 PDT
But bug 180568 is even more suspicious. That change was actually briefly landed, rolled back, and landed again. The test failed once when it was first landed, and then started to fail again after it was re-landed.
Comment 3 Radar WebKit Bug Importer 2018-03-28 15:45:07 PDT
<rdar://problem/38975570>
Comment 4 youenn fablet 2018-05-09 04:20:58 PDT
Created attachment 339952 [details]
Patch
Comment 5 EWS Watchlist 2018-05-09 05:25:15 PDT
Comment on attachment 339952 [details]
Patch

Attachment 339952 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/7622605

New failing tests:
http/tests/appcache/interrupted-update.html
Comment 6 EWS Watchlist 2018-05-09 05:25:17 PDT
Created attachment 339956 [details]
Archive of layout-test-results from ews100 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 7 EWS Watchlist 2018-05-09 05:30:21 PDT
Comment on attachment 339952 [details]
Patch

Attachment 339952 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/7622608

New failing tests:
http/tests/appcache/interrupted-update.html
Comment 8 EWS Watchlist 2018-05-09 05:30:27 PDT
Created attachment 339957 [details]
Archive of layout-test-results from ews107 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 9 youenn fablet 2018-05-09 10:39:14 PDT
Created attachment 339982 [details]
Patch
Comment 10 youenn fablet 2018-05-09 12:17:44 PDT
I made http/tests/appcache/interrupted-update.html not rely on local storage which seems to be the cause of the trouble.
I added a local-storage+reload test as a way to continue tracking this potential issue.
Comment 11 youenn fablet 2018-05-17 13:01:22 PDT
ping review
Comment 12 WebKit Commit Bot 2018-05-17 13:40:53 PDT
Comment on attachment 339982 [details]
Patch

Clearing flags on attachment: 339982

Committed r231918: <https://trac.webkit.org/changeset/231918>
Comment 13 WebKit Commit Bot 2018-05-17 13:40:55 PDT
All reviewed patches have been landed.  Closing bug.