Bug 183464 - Windows JavaScriptCore build broken
Summary: Windows JavaScriptCore build broken
Status: RESOLVED DUPLICATE of bug 183465
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-08 11:15 PST by Ryan Haddad
Modified: 2018-03-08 11:26 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-03-08 11:15:02 PST
C:\cygwin\home\buildbot\slave\win-release\build\Source\JavaScriptCore\jsc.cpp(1055): error C2065: '__asm__': undeclared identifier [C:\cygwin\home\buildbot\slave\win-release\build\WebKitBuild\Release\Source\JavaScriptCore\shell\jscLib.vcxproj]
C:\cygwin\home\buildbot\slave\win-release\build\Source\JavaScriptCore\jsc.cpp(1055): error C2143: syntax error: missing ';' before 'volatile' [C:\cygwin\home\buildbot\slave\win-release\build\WebKitBuild\Release\Source\JavaScriptCore\shell\jscLib.vcxproj]
C:\cygwin\home\buildbot\slave\win-release\build\Source\JavaScriptCore\jsc.cpp(1055): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int [C:\cygwin\home\buildbot\slave\win-release\build\WebKitBuild\Release\Source\JavaScriptCore\shell\jscLib.vcxproj]
C:\cygwin\home\buildbot\slave\win-release\build\Source\JavaScriptCore\jsc.cpp(1055): error C2059: syntax error: 'string' [C:\cygwin\home\buildbot\slave\win-release\build\WebKitBuild\Release\Source\JavaScriptCore\shell\jscLib.vcxproj]

https://build.webkit.org/builders/Apple%20Win%20Release%20%28Build%29/builds/8171
Comment 1 Ryan Haddad 2018-03-08 11:15:28 PST
Looking at build history, it appears that this failure started with https://trac.webkit.org/changeset/229391
Comment 2 Keith Miller 2018-03-08 11:16:31 PST
I have a fix for this incoming soon.
Comment 3 Ryan Haddad 2018-03-08 11:26:56 PST

*** This bug has been marked as a duplicate of bug 183465 ***