Bug 18033 - Acid3 tests 69, 74, and 78 fail on PPC (for some people, not everyone)
: Acid3 tests 69, 74, and 78 fail on PPC (for some people, not everyone)
Status: RESOLVED DUPLICATE of bug 17884
Product: WebKit
Classification: Unclassified
Component: SVG
: 528+ (Nightly build)
: Macintosh PowerPC Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks: Acid3
  Show dependency treegraph
 
Reported: 2008-03-23 19:53 PDT by Yuen Ho Wong
Modified: 2008-03-28 08:30 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuen Ho Wong 2008-03-23 19:53:35 PDT
See comment 22 and 25 on this link.

http://webkit.org/blog/167/webkit-gets-an-a-on-acid3/#comments

Thomas Ganter seems to be using Leopard whereas I'm using Tiger, so the only common denominator is PPC. I've isolated down to these 3 tests that are reported fixed but still failing on PPC.

To save you some potential headache. I've used Monolingual to remove the extra languages, and stripped the binary of non-G4 architecture binary code.
Comment 1 Alexey Proskuryakov 2008-03-24 01:42:54 PDT
FWIW, I do not see this on my G4/1.25DP - both a local debug build and r31238 nightly pass these tests, and give a 95/100 overall. Testing on 10.4.11 with Safari 3.0.4.

Test 69 often gives warnings such as "took 44 attempts".

I did see failure of test 77 once, but that is tracked as bug 17672.
Comment 2 Yuen Ho Wong 2008-03-24 18:29:37 PDT
For 78, it's probably bug 17063 because the error messages match.

I don't see anything related to 69 or 74 anywhere however.
Comment 3 David Kilzer (:ddkilzer) 2008-03-25 13:53:34 PDT
(In reply to comment #0)
> To save you some potential headache. I've used Monolingual to remove the extra
> languages, and stripped the binary of non-G4 architecture binary code.

This is an unsupported configuration.  Results after performing such a change are not valid.

Comment 4 Yuen Ho Wong 2008-03-25 14:24:37 PDT
I forgot to mention that running the universal Webkit nightly without stripping also has this problem.

I can't really unstrip my system so I can't test whether it is some other libraries Webkit is referencing is causing the problem or Webkit itself.

Not sure if Thomas Ganter has ran Monolingual. He certainly didn't mention it. If he hasn't, or done anything weird to his binaries, then it's not a problem of Monolingual.
Comment 5 hahn.seb 2008-03-28 08:16:00 PDT
This should be a duplicate of http://bugs.webkit.org/show_bug.cgi?id=17884
Comment 6 Alexey Proskuryakov 2008-03-28 08:30:33 PDT
Indeed.

*** This bug has been marked as a duplicate of 17884 ***