Bug 17913 - Webkit fails to import style sheet file because of @media screen, print { }
Summary: Webkit fails to import style sheet file because of @media screen, print { }
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Major
Assignee: Nobody
URL: https://oi.cajamadrid.es/
Keywords: HasReduction, InRadar
: 19957 (view as bug list)
Depends on: 14346
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 09:11 PDT by Iván Garcia
Modified: 2008-12-26 09:04 PST (History)
5 users (show)

See Also:


Attachments
test case (213 bytes, text/html)
2008-03-18 13:22 PDT, Robert Blaut
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iván Garcia 2008-03-18 09:11:00 PDT
Internet Office of a Spanish Bank is not allowed by Safari or Webkit nighty builds.
Comment 1 Robert Blaut 2008-03-18 13:22:27 PDT
Created attachment 19869 [details]
test case

The test case clearly shows that Webkit fails to import the stylesheet file.
Comment 2 Robert Blaut 2008-03-18 13:25:22 PDT
Confirmed.
Comment 3 Robert Blaut 2008-03-18 13:36:01 PDT
@media screen, print { } in the style sheet file: https://oi.cajamadrid.es/CajaMadrid/oi/css/estilos_oiv1_1.css causes this problem
Comment 4 Mark Rowe (bdash) 2008-03-18 19:00:49 PDT
<rdar://problem/5806715>
Comment 5 Iván Garcia 2008-04-03 10:41:14 PDT
I have sent a message to the webmaster of cajamadrid telling this problem. I'm waiting a response.
Comment 6 Iván Garcia 2008-08-26 03:56:37 PDT
Solved.
In the last version of Webkit, now https://oi.cajamadrid.es/ works, but in safari 3.1 with "normal" core keep doesn't working. So thanks Webkit team.


Thanks
Comment 7 Robert Blaut 2008-08-26 04:42:18 PDT
The bug was fixed in http://trac.webkit.org/changeset/35403
Comment 8 Robert Blaut 2008-12-26 09:04:39 PST
*** Bug 19957 has been marked as a duplicate of this bug. ***