Bug 179035 - Crash under WebKit::CacheStorage::Caches::initializeSize(WTF::Function<void (std::optional<WebCore::DOMCacheEngine::Error>&&)>&&) + 30 (CacheStorageEngineCaches.cpp:163)
Summary: Crash under WebKit::CacheStorage::Caches::initializeSize(WTF::Function<void (...
Status: RESOLVED DUPLICATE of bug 179037
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-30 16:33 PDT by Chris Dumez
Modified: 2017-11-28 16:18 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2017-10-30 16:33:44 PDT
Crash under WebKit::CacheStorage::Caches::initializeSize(WTF::Function<void (std::optional<WebCore::DOMCacheEngine::Error>&&)>&&) + 30 (CacheStorageEngineCaches.cpp:163):
Thread 0 Crashed:: Dispatch queue: com.apple.libdispatch-io.opq
0   com.apple.WebKit              	0x0000000109ee80d4 WebKit::CacheStorage::Caches::initializeSize(WTF::Function<void (std::optional<WebCore::DOMCacheEngine::Error>&&)>&&) + 30 (CacheStorageEngineCaches.cpp:163)
1   com.apple.WebKit              	0x0000000109ee9e41 WTF::Function<void (WTF::Expected<WTF::Vector<WebKit::CacheStorage::Cache, 0ul, WTF::CrashOnOverflow, 16ul, WTF::FastMalloc>, WebCore::DOMCacheEngine::Error>&&)>::CallableWrapper<WebKit::CacheStorage::Caches::initialize(WTF::Function<void (std::optional<WebCore::DOMCacheEngine::Error>&&)>&&)::$_3::operator()(std::optional<WebCore::DOMCacheEngine::Error>&&)::'lambda'(WTF::Expected<WTF::Vector<WebKit::CacheStorage::Cache, 0ul, WTF::CrashOnOverflow, 16ul, WTF::FastMalloc>, WebCore::DOMCacheEngine::Error>&&)>::call(WTF::Expected<WTF::Vector<WebKit::CacheStorage::Cache, 0ul, WTF::CrashOnOverflow, 16ul, WTF::FastMalloc>, WebCore::DOMCacheEngine::Error>&&) + 97 (CacheStorageEngineCaches.cpp:155)
2   com.apple.WebKit              	0x0000000109ee8c72 WebKit::CacheStorage::Caches::readCachesFromDisk(WTF::Function<void (WTF::Expected<WTF::Vector<WebKit::CacheStorage::Cache, 0ul, WTF::CrashOnOverflow, 16ul, WTF::FastMalloc>, WebCore::DOMCacheEngine::Error>&&)>&&) + 374 (CacheStorageEngineCaches.cpp:337)
3   com.apple.WebKit              	0x0000000109ee9d5b WTF::Function<void (std::optional<WebCore::DOMCacheEngine::Error>&&)>::CallableWrapper<WebKit::CacheStorage::Caches::initialize(WTF::Function<void (std::optional<WebCore::DOMCacheEngine::Error>&&)>&&)::$_3>::call(std::optional<WebCore::DOMCacheEngine::Error>&&) + 103 (CacheStorageEngineCaches.cpp:142)
4   com.apple.WebKit              	0x0000000109ed4d2c WTF::Function<void (int)>::CallableWrapper<WebKit::CacheStorage::Engine::writeFile(WTF::String const&, WebKit::NetworkCache::Data&&, WTF::Function<void (std::optional<WebCore::DOMCacheEngine::Error>&&)>&&)::$_9::operator()()::'lambda'(int)>::call(int) + 54 (Function.h:101)
5   libdispatch.dylib             	0x00007fff9b306c0b ___dispatch_operation_deliver_data_block_invoke + 118
6   libdispatch.dylib             	0x00007fff9b2f193d _dispatch_call_block_and_release + 12
7   libdispatch.dylib             	0x00007fff9b2e640b _dispatch_client_callout + 8
8   libdispatch.dylib             	0x00007fff9b2eb03b _dispatch_queue_drain + 754
9   libdispatch.dylib             	0x00007fff9b2f1707 _dispatch_queue_invoke + 549
10  libdispatch.dylib             	0x00007fff9b2f972d _dispatch_main_queue_callback_4CF + 422
11  com.apple.CoreFoundation      	0x00007fff921f7949 __CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE__ + 9
12  com.apple.CoreFoundation      	0x00007fff921b682d __CFRunLoopRun + 1949
13  com.apple.CoreFoundation      	0x00007fff921b5e28 CFRunLoopRunSpecific + 296
14  com.apple.Foundation          	0x00007fff9293cf99 -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 270
15  com.apple.Foundation          	0x00007fff9293ce78 -[NSRunLoop(NSRunLoop) run] + 74
16  libxpc.dylib                  	0x00007fff91a13168 _xpc_objc_main + 751
17  libxpc.dylib                  	0x00007fff91a11bbe xpc_main + 494
18  com.apple.WebKit.Networking   	0x0000000109e8b702 main + 534
19  libdyld.dylib                 	0x00007fff91d0d5ad start + 1

when enabling Web-platform tests.
Comment 1 Chris Dumez 2017-10-30 16:35:50 PDT
Committed r224211: <https://trac.webkit.org/changeset/224211>
Comment 2 Chris Dumez 2017-10-30 16:36:04 PDT
Tests temporarily skipped in  <https://trac.webkit.org/changeset/224211>.
Comment 3 Chris Dumez 2017-10-30 16:36:17 PDT
Was just skipping.
Comment 4 Chris Dumez 2017-10-30 16:39:02 PDT
*** Bug 179037 has been marked as a duplicate of this bug. ***
Comment 5 youenn fablet 2017-11-28 16:18:00 PST

*** This bug has been marked as a duplicate of bug 179037 ***