Bug 178387 - [GTK] Artifacts while browsing Google+ and GitLab in accelerated compositing mode
Summary: [GTK] Artifacts while browsing Google+ and GitLab in accelerated compositing ...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 192523
  Show dependency treegraph
 
Reported: 2017-10-17 07:31 PDT by Cédric Bellegarde
Modified: 2019-01-28 07:38 PST (History)
4 users (show)

See Also:


Attachments
Artefacts while browsing Google+ (742.03 KB, image/png)
2017-10-17 07:31 PDT, Cédric Bellegarde
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Bellegarde 2017-10-17 07:31:50 PDT
Created attachment 324014 [details]
Artefacts while browsing Google+

Since WebKitGTK 2.18.0, there are some artefacts on Google+.

Kernel: 4.13.7-1-ARCH
Video card: Intel Corporation Haswell-ULT Integrated Graphics Controller
DE: Gnome Shell with Xorg

See attachment.
Comment 1 Cédric Bellegarde 2017-10-23 23:46:09 PDT
WEBKIT_DISABLE_COMPOSITING_MODE fixes the issue.
Comment 2 Cédric Bellegarde 2017-11-28 03:52:28 PST
Fixed in 2.18.3
Comment 3 Cédric Bellegarde 2018-04-18 08:32:31 PDT
Bad news, the bug is always here. Easy to reproduce with epiphany, just scroll in the page. Related to COMPOSITING_MODE.
Comment 4 Michael Catanzaro 2018-04-18 09:23:53 PDT
I see this bug regularly on GitLab (gitlab.com or gitlab.gnome.org).
Comment 5 Michael Catanzaro 2019-01-28 07:38:41 PST
(In reply to Michael Catanzaro from comment #4)
> I see this bug regularly on GitLab (gitlab.com or gitlab.gnome.org).

This bug might be stale. Certainly a similar issue was recently fixed in bug #192230. I'm not sure, but I'm going to consider it obsolete. If someone notices a new issue, a new bug can be reported.