Bug 176856 - [GTK] fast/mediastream/apply-constraints-video.html has begun to crash sometimes
Summary: [GTK] fast/mediastream/apply-constraints-video.html has begun to crash sometimes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-13 10:39 PDT by Alicia Boya García
Modified: 2018-06-26 14:53 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alicia Boya García 2017-09-13 10:39:41 PDT
The first failure reported by the bots it's in r221942. 

Since then it has flaky behavior.

The same has happened almost simultaneously with this WebRTC test, so it may be
related (e.g. a regression in MediaPlayer maybe?), but it could have also been
by chance:

webrtc/clone-audio-track.html
https://bugs.webkit.org/show_bug.cgi?id=176850
Comment 1 Alicia Boya García 2017-09-13 14:27:10 PDT
Marked as expected crash in r221992.

Please update expectations when fixed.
Comment 2 Thibault Saunier 2018-06-26 14:53:55 PDT
That test has been fixed in the new implementation of MediaStream (r232589) and is now enabled in the exectations. Closing