Bug 175678 - media/W3C/video/events/event_progress.html is flaky.
Summary: media/W3C/video/events/event_progress.html is flaky.
Status: RESOLVED DUPLICATE of bug 181966
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Peng Liu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-17 10:43 PDT by Matt Lewis
Modified: 2019-10-10 14:20 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lewis 2017-08-17 10:43:20 PDT
media/W3C/video/events/event_progress.html is flaky on wk2 according to the flakiness dashboard.

First failure on the board is with this build: https://build.webkit.org/builders/Apple%20El%20Capitan%20Debug%20WK2%20(Tests)/builds/2128
However this does not look to be the regression point.

Current results: https://build.webkit.org/results/Apple%20El%20Capitan%20Debug%20WK2%20(Tests)/r220854%20(2599)/results.html

Diff:

--- /Volumes/Data/slave/elcapitan-debug-tests-wk2/build/layout-test-results/media/W3C/video/events/event_progress-expected.txt
+++ /Volumes/Data/slave/elcapitan-debug-tests-wk2/build/layout-test-results/media/W3C/video/events/event_progress-actual.txt
@@ -6,6 +6,9 @@
 PASS true is true
 
 TEST COMPLETE
+PASS true is true
+
+TEST COMPLETE
 spec reference
Comment 1 Matt Lewis 2017-09-05 12:56:50 PDT
Marked as flaky on WK2:
https://trac.webkit.org/changeset/221629/webkit
Comment 2 Ryan Haddad 2019-05-07 09:37:40 PDT
This is also happening on WK1 bots. Updated test expectations in https://trac.webkit.org/r245013
Comment 3 Peng Liu 2019-10-10 14:20:15 PDT
This test case will fail when the video element fires more than one "progress" event before the test case complete.

*** This bug has been marked as a duplicate of bug 181966 ***