Bug 17397 - REGRESSION (r30236-30336): Cannot backspace/enter in forms on Windows
Summary: REGRESSION (r30236-30336): Cannot backspace/enter in forms on Windows
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P1 Critical
Assignee: Nobody
URL: data:text/html,<input type="text" val...
Keywords: InRadar, PlatformOnly, Regression
Depends on:
Blocks:
 
Reported: 2008-02-16 17:21 PST by Matt Lilek
Modified: 2008-02-17 15:20 PST (History)
1 user (show)

See Also:


Attachments
proposed fix (untested) (5.74 KB, patch)
2008-02-17 00:03 PST, Alexey Proskuryakov
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2008-02-16 17:21:59 PST
Backspace, enter, paste, etc are all broken in the address bar and search box in Safari on Windows. This extends to standard form controls as well - loading the above HTML snippet and pressing backspace after focusing the input causes the previous page to be loaded.
Comment 1 Mark Rowe (bdash) 2008-02-16 18:35:26 PST
<rdar://problem/5748245>
Comment 2 Alexey Proskuryakov 2008-02-16 23:38:17 PST
This is caused by mismatching ENABLE_CROSS_DOCUMENT_MESSAGING macros between WebKit and WebCore projects. This problem was supposed to be fixed in r30276, but apparently some configurations remained wrong.
Comment 3 Alexey Proskuryakov 2008-02-16 23:40:32 PST
Um, not r30276 - that was a Mac-only change. Anyway, this was supposed to be fixed :)
Comment 4 Alexey Proskuryakov 2008-02-17 00:03:07 PST
Created attachment 19169 [details]
proposed fix (untested)

My build isn't finished yet, and I have to leave for a day, but this should fix the problem.
Comment 5 Darin Adler 2008-02-17 07:26:38 PST
Comment on attachment 19169 [details]
proposed fix (untested)

r=me
Comment 6 Alexey Proskuryakov 2008-02-17 12:23:23 PST
Committed revision 30358 (with fingers crossed, as I haven't built yet).
Comment 7 Matt Lilek 2008-02-17 15:20:35 PST
(In reply to comment #6)
> Committed revision 30358 (with fingers crossed, as I haven't built yet).
> 

It works :)