Bug 170890 - Web Inspector: XHR breakpoints restored from settings do not appear in the sidebar
Summary: Web Inspector: XHR breakpoints restored from settings do not appear in the si...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P1 Normal
Assignee: Matt Baker
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-04-16 12:46 PDT by Matt Baker
Modified: 2017-04-17 12:31 PDT (History)
6 users (show)

See Also:


Attachments
Patch (3.14 KB, patch)
2017-04-16 12:50 PDT, Matt Baker
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews104 for mac-elcapitan-wk2 (898.43 KB, application/zip)
2017-04-16 14:08 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Baker 2017-04-16 12:46:34 PDT
Summary:
XHR breakpoints restored from settings do not appear in the sidebar. Breakpoints added from the UI appear as expected.

Steps to Reproduce:
1. Open Debugger tab
2. Add an XHR breakpoint
  => Breakpoint added to sidebar
3. Reload the page
  => Breakpoint disappears

Note that the breakpoint will still cause the page to break, since the problem is not in DOMDebuggerManager.
Comment 1 Radar WebKit Bug Importer 2017-04-16 12:47:37 PDT
<rdar://problem/31649271>
Comment 2 Matt Baker 2017-04-16 12:50:32 PDT
Created attachment 307236 [details]
Patch
Comment 3 Build Bot 2017-04-16 14:08:56 PDT
Comment on attachment 307236 [details]
Patch

Attachment 307236 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/3547237

New failing tests:
webrtc/multi-video.html
Comment 4 Build Bot 2017-04-16 14:08:57 PDT
Created attachment 307239 [details]
Archive of layout-test-results from ews104 for mac-elcapitan-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews104  Port: mac-elcapitan-wk2  Platform: Mac OS X 10.11.6
Comment 5 Joseph Pecoraro 2017-04-17 12:02:38 PDT
Comment on attachment 307236 [details]
Patch

r=me
Comment 6 WebKit Commit Bot 2017-04-17 12:30:59 PDT
Comment on attachment 307236 [details]
Patch

Clearing flags on attachment: 307236

Committed r215422: <http://trac.webkit.org/changeset/215422>
Comment 7 WebKit Commit Bot 2017-04-17 12:31:00 PDT
All reviewed patches have been landed.  Closing bug.