Bug 167757 - LayoutTest workers/bomb.html is a Crash
Summary: LayoutTest workers/bomb.html is a Crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-02-02 14:33 PST by Ryan Haddad
Modified: 2017-07-03 22:18 PDT (History)
15 users (show)

See Also:


Attachments
Diff (111.09 KB, text/plain)
2017-05-15 17:37 PDT, Matt Lewis
no flags Details
patch (5.37 KB, patch)
2017-07-03 19:57 PDT, Saam Barati
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2017-02-02 14:33:40 PST
LayoutTest workers/bomb.html is a flaky timeout

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=workers%2Fbomb.html
Comment 1 Ryan Haddad 2017-02-02 14:34:38 PST
This appears to be limited to Sierra Release.
Comment 2 Ryan Haddad 2017-02-02 14:48:11 PST
This is not a recent regression. I went ahead and marked the test as flaky in http://trac.webkit.org/projects/webkit/changeset/211595
Comment 4 Matt Lewis 2017-06-06 16:46:44 PDT
Marked as flaky on iOS WK2 Release:
https://trac.webkit.org/changeset/217868/webkit/
Comment 5 Yusuke Suzuki 2017-06-27 18:06:48 PDT
i've just speculatively unmarked it due to the fix in https://bugs.webkit.org/show_bug.cgi?id=173888
Comment 6 David Kilzer (:ddkilzer) 2017-06-28 04:42:35 PDT
(In reply to Yusuke Suzuki from comment #5)
> i've just speculatively unmarked it due to the fix in
> https://bugs.webkit.org/show_bug.cgi?id=173888

Resolving this based on the comment above (since no TestExpectations file is referencing this bug anymore).
Comment 7 Saam Barati 2017-07-03 11:31:13 PDT
Marking as flaky again on iOS/mac. Tracking it here:
https://bugs.webkit.org/show_bug.cgi?id=171985
Comment 8 Matt Lewis 2017-07-03 13:32:43 PDT
<rdar://problem/33086462>
Comment 9 Matt Lewis 2017-07-03 13:34:56 PDT
(In reply to Matt Lewis from comment #8)
> <rdar://problem/33086462>

The test has turned into a fairly consistent crash. Associating this bug with the radar and reopening bug as the proposed fix does not appear to have fixed the issues with this test.
Comment 10 Matt Lewis 2017-07-03 16:35:40 PDT
Skipped test on macOS WK2 as it is a consistent crash:
https://trac.webkit.org/changeset/219107/webkit/
Comment 11 Saam Barati 2017-07-03 18:28:02 PDT
I'm working on this now
Comment 12 Saam Barati 2017-07-03 19:57:49 PDT
Created attachment 314548 [details]
patch
Comment 13 Keith Miller 2017-07-03 20:06:24 PDT
Comment on attachment 314548 [details]
patch

r=me.
Comment 14 WebKit Commit Bot 2017-07-03 22:18:18 PDT
Comment on attachment 314548 [details]
patch

Clearing flags on attachment: 314548

Committed r219114: <http://trac.webkit.org/changeset/219114>
Comment 15 WebKit Commit Bot 2017-07-03 22:18:20 PDT
All reviewed patches have been landed.  Closing bug.