Bug 167548 - [GTK] ASSERTION FAILED: !m_layerTreeHost in DrawingAreaImpl::display()
Summary: [GTK] ASSERTION FAILED: !m_layerTreeHost in DrawingAreaImpl::display()
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2017-01-28 02:23 PST by Carlos Garcia Campos
Modified: 2017-01-28 23:15 PST (History)
1 user (show)

See Also:


Attachments
Patch (1.88 KB, patch)
2017-01-28 02:25 PST, Carlos Garcia Campos
mcatanzaro: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2017-01-28 02:23:15 PST
The problem is that non accelerated compositing forceRepaint implementation is doing a layout and then calling display. The layout makes the drawing area enter in AC mode and display asserts that we have a layer tree host. forceRepaint shouldn't do the layout because display already does that and it correctly handles the case of entering AC mode during the layout. It shouldn't call setNeedsDisplay either, because that schedules a display, but we are going to display synchronously.
Comment 1 Carlos Garcia Campos 2017-01-28 02:25:11 PST
Created attachment 300016 [details]
Patch
Comment 2 Carlos Garcia Campos 2017-01-28 23:15:44 PST
Committed r211346: <http://trac.webkit.org/changeset/211346>