Bug 167500 - Merge CachedModuleScript and LoadableModuleScript
Summary: Merge CachedModuleScript and LoadableModuleScript
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
Depends on:
Blocks: 167501
  Show dependency treegraph
Reported: 2017-01-27 07:26 PST by Yusuke Suzuki
Modified: 2017-01-27 16:48 PST (History)
3 users (show)

See Also:

Patch (32.55 KB, patch)
2017-01-27 07:28 PST, Yusuke Suzuki
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuke Suzuki 2017-01-27 07:26:13 PST
Merge CachedModuleScript and LoadableModuleScript
Comment 1 Yusuke Suzuki 2017-01-27 07:28:30 PST
Created attachment 299932 [details]
Comment 2 WebKit Commit Bot 2017-01-27 07:31:38 PST
Attachment 299932 [details] did not pass style-queue:

ERROR: Source/WebCore/bindings/js/ScriptController.cpp:383:  'moduleScript' is incorrectly named. It should be named 'protector' or 'protectedModuleScriptRef'.  [readability/naming/protected] [4]
Total errors found: 1 in 7 files

If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Yusuke Suzuki 2017-01-27 16:23:34 PST
Comment on attachment 299932 [details]

Comment 4 WebKit Commit Bot 2017-01-27 16:48:53 PST
Comment on attachment 299932 [details]

Clearing flags on attachment: 299932

Committed r211313: <http://trac.webkit.org/changeset/211313>
Comment 5 WebKit Commit Bot 2017-01-27 16:48:57 PST
All reviewed patches have been landed.  Closing bug.