Bug 167348 - LayoutTest media/modern-media-controls/media-controller/media-controller-auto-hide-mouse-enter-and-mouse-leave.html is a flaky failure
Summary: LayoutTest media/modern-media-controls/media-controller/media-controller-auto...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-01-23 17:35 PST by Ryan Haddad
Modified: 2017-03-02 18:44 PST (History)
3 users (show)

See Also:


Attachments
Patch (8.04 KB, patch)
2017-03-02 17:49 PST, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2017-01-23 17:35:00 PST
LayoutTest media/modern-media-controls/media-controller/media-controller-auto-hide-mouse-enter-and-mouse-leave.html is a flaky failure

https://build.webkit.org/results/Apple%20Sierra%20Release%20WK2%20(Tests)/r211060%20(2908)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=media%2Fmodern-media-controls%2Fmedia-controller%2Fmedia-controller-auto-hide-mouse-enter-and-mouse-leave.html

--- /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/media/modern-media-controls/media-controller/media-controller-auto-hide-mouse-enter-and-mouse-leave-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/media/modern-media-controls/media-controller/media-controller-auto-hide-mouse-enter-and-mouse-leave-actual.txt
@@ -7,7 +7,7 @@
 PASS controlsBar.classList.contains('faded') is false
 
 Auto-hide timer has elapsed, controls bar should be faded.
-PASS controlsBar.classList.contains('faded') is true
+FAIL controlsBar.classList.contains('faded') should be true. Was false.
 
 Mouse moved over the media, controls bar should be visible.
 PASS controlsBar.classList.contains('faded') is false
Comment 1 Ryan Haddad 2017-01-23 18:36:11 PST
Marked as flaky in https://trac.webkit.org/changeset/211073
Comment 2 Antoine Quint 2017-01-25 05:38:29 PST
This is tricky because this test, and a host of others, is timing-sensitive by design since it's testing the auto-hide timer. The test checks as close as possible to the auto-hide delay that the controls are still visible, and then again as soon as possible after the auto-hide delay has elapsed to check that the controls are no longer visible. So in certain cases, probably where the system is under pressure and timers run late, we get in cases where the check prior to the timer firing fails because we've actually run past auto-hide delay. We're going to have to find a different way to test this.
Comment 3 Radar WebKit Bug Importer 2017-03-02 17:48:03 PST
<rdar://problem/30822186>
Comment 4 Antoine Quint 2017-03-02 17:49:08 PST
Created attachment 303274 [details]
Patch
Comment 5 WebKit Commit Bot 2017-03-02 18:44:27 PST
Comment on attachment 303274 [details]
Patch

Clearing flags on attachment: 303274

Committed r213340: <http://trac.webkit.org/changeset/213340>
Comment 6 WebKit Commit Bot 2017-03-02 18:44:32 PST
All reviewed patches have been landed.  Closing bug.