Bug 166979 - [MSE, Audio only] Playback does not resume after seeking to an unbuffered position
Summary: [MSE, Audio only] Playback does not resume after seeking to an unbuffered pos...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: Safari 10
Hardware: Mac OS X 10.11
: P2 Major
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-01-12 11:27 PST by gregory marcilhacy
Modified: 2019-08-19 14:36 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gregory marcilhacy 2017-01-12 11:27:46 PST
I found a similar issue from 2 years ago: https://bugs.webkit.org/show_bug.cgi?id=135591

Repro steps:
- Visit http://players.akamai.com/dash/
- Load http://vm2.dashif.org/dash/vod/testpic_2s/audio.mpd
- Seek to the middle of the track
- Observa that playback does not resume
- Wait a few minutes and playback will eventually resume...
Comment 1 gregory marcilhacy 2017-01-12 16:48:06 PST
This seems to fix the issue but this should still be addressed.


...
audioElement.addEventListener('seeked', function(){
  audioElement.currentTime = audioElement.currentTime;
});
Comment 2 Radar WebKit Bug Importer 2017-01-14 00:25:19 PST
<rdar://problem/30026480>
Comment 3 Jer Noble 2017-01-14 08:08:46 PST
Interesting, thanks for the report!
Comment 4 gregory marcilhacy 2017-02-14 17:16:23 PST
Any update?
Comment 5 Jer Noble 2017-02-14 21:08:44 PST
I haven't had a chance to look st this yet, sorry. 🙁
Comment 6 Peng Liu 2019-08-19 12:52:11 PDT
I cannot reproduce it with the Safari Technology Preview, release 89.