Bug 16636 - Acid3 expects document.firstChild to be a DocType node
Summary: Acid3 expects document.firstChild to be a DocType node
Status: RESOLVED DUPLICATE of bug 12751
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.hixie.ch/tests/evil/acid/0...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-28 01:45 PST by Eric Seidel (no email)
Modified: 2007-12-28 07:00 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-12-28 01:45:31 PST
Acid3 expects document.firstChild to be a DocType node

http://www.hixie.ch/tests/evil/acid/003/NOT_READY_PLEASE_DO_NOT_USE.html

We pass all parts of 33 except for this check:
 (document.firstChild.nodeType == 10)) // doctype

    function () {
      // test 33: nodeType (this test also relies on accurate parsing of the document)
      if ((document.nodeType == 9) && // document
          (document.documentElement.nodeType == 1) && // element
          (document.createAttribute('test').nodeType == 2) && // attribute
          (document.getElementById('score').firstChild.nodeType == 3) && // test node
          (document.firstChild.nodeType == 10)) // doctype
        return 3;
    },
Comment 1 Alexey Proskuryakov 2007-12-28 07:00:40 PST
NOT_READY_PLEASE_DO_NOT_USE

*** This bug has been marked as a duplicate of 12751 ***