Bug 164388 - REGRESSION: inspector/sampling-profiler/* LayoutTests are flaky timeouts
Summary: REGRESSION: inspector/sampling-profiler/* LayoutTests are flaky timeouts
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 164399 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-03 16:34 PDT by Ryan Haddad
Modified: 2016-11-30 14:21 PST (History)
12 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-01 (946.83 KB, application/zip)
2016-11-09 10:56 PST, WebKit Commit Bot
no flags Details
[PATCH] Proposed Fix (3.32 KB, patch)
2016-11-30 13:41 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff
[PATCH] Proposed Fix (4.06 KB, patch)
2016-11-30 13:42 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Ryan Haddad 2016-11-03 17:00:43 PDT
Marked tests as flaky in http://trac.webkit.org/projects/webkit/changeset/208358
Comment 2 Radar WebKit Bug Importer 2016-11-03 17:01:21 PDT
<rdar://problem/29101555>
Comment 3 Ryan Haddad 2016-11-03 17:01:38 PDT
Could this have anything to do with http://trac.webkit.org/changeset/208309?
Comment 4 BJ Burg 2016-11-03 20:35:21 PDT
Seems very unlikely.
Comment 5 Alexey Proskuryakov 2016-11-05 09:59:52 PDT
*** Bug 164399 has been marked as a duplicate of this bug. ***
Comment 6 WebKit Commit Bot 2016-11-09 10:56:42 PST
The commit-queue just saw inspector/sampling-profiler/call-frame-with-dom-functions.html flake (test timed out) while processing attachment 294234 [details] on bug 164459.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.10.5
Comment 7 WebKit Commit Bot 2016-11-09 10:56:43 PST
Created attachment 294239 [details]
Archive of layout-test-results from webkit-cq-01
Comment 8 Ryan Haddad 2016-11-10 12:04:50 PST
It looks like many/all of the inspector/sampling-profiler tests are flaky timeouts now:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector%2Fsampling-profiler%2F
Comment 9 Joseph Pecoraro 2016-11-30 13:41:30 PST
Created attachment 295756 [details]
[PATCH] Proposed Fix
Comment 10 Joseph Pecoraro 2016-11-30 13:42:18 PST
Created attachment 295757 [details]
[PATCH] Proposed Fix
Comment 11 WebKit Commit Bot 2016-11-30 14:21:37 PST
Comment on attachment 295757 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 295757

Committed r209154: <http://trac.webkit.org/changeset/209154>
Comment 12 WebKit Commit Bot 2016-11-30 14:21:41 PST
All reviewed patches have been landed.  Closing bug.