Bug 16430 - Repeated file database access seems to lock database
Summary: Repeated file database access seems to lock database
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-13 21:03 PST by Brent Fulgham
Modified: 2007-12-13 23:55 PST (History)
0 users

See Also:


Attachments
Sample file database from the HTML5 database example (C:\Documents and Settings\bfulgham\Local Settings\Application Data\Apple Computer\Safari\Databases\http_webkit.org_0) after the lock out error. (7.00 KB, application/octet-stream)
2007-12-13 21:04 PST, Brent Fulgham
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2007-12-13 21:03:15 PST
Playing with the HTML5 database implementation (http://webkit.org/misc/DatabaseExample.html) using a nightly build (sources from 10 am on 12/13/2007) under Windows XP:
1.  Start Safari (run-safari).  Open the example and create a few notes.
2.  Close Safari.  Reopen Safari.
3.  View notes, move them around, etc.
4.  Close Safari. Reopen Safari.
5.  Error message:  "Failed to open the database on disk".

Note:  I observed this after implementing changes to the threading primatives (see bug http://bugs.webkit.org/show_bug.cgi?id=16428) which may be the cause.
Comment 1 Brent Fulgham 2007-12-13 21:04:40 PST
Created attachment 17886 [details]
Sample file database from the HTML5 database example (C:\Documents and Settings\bfulgham\Local Settings\Application Data\Apple Computer\Safari\Databases\http_webkit.org_0) after the lock out error.

This is the result of the test case mentioned in the bug description.  I can't open this file to access the data.
Comment 2 Brent Fulgham 2007-12-13 23:55:43 PST
This is due to my thread changes.  After backing them out, it seems to work properly.