Bug 164080 - REGRESSION: http/tests/websocket/tests/hybi/closed-when-entering-page-cache.html and http/tests/websocket/tests/hybi/stop-on-resume-in-error-handler.html are flaky
Summary: REGRESSION: http/tests/websocket/tests/hybi/closed-when-entering-page-cache.h...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-10-27 14:32 PDT by Ryan Haddad
Modified: 2016-11-29 12:52 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-10-27 14:32:40 PDT
http/tests/websocket/tests/hybi/closed-when-entering-page-cache.html and http/tests/websocket/tests/hybi/stop-on-resume-in-error-handler.html are flaky

https://build.webkit.org/results/Apple%20Yosemite%20Release%20WK1%20(Tests)/r207990%20(19318)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2Fwebsocket%2Ftests%2Fhybi%2Fclosed-when-entering-page-cache.html
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2Fwebsocket%2Ftests%2Fhybi%2Fstop-on-resume-in-error-handler.html

--- /Volumes/Data/slave/yosemite-release-tests-wk1/build/layout-test-results/http/tests/websocket/tests/hybi/closed-when-entering-page-cache-expected.txt
+++ /Volumes/Data/slave/yosemite-release-tests-wk1/build/layout-test-results/http/tests/websocket/tests/hybi/closed-when-entering-page-cache-actual.txt
@@ -1,21 +1 @@
-CONSOLE MESSAGE: WebSocket connection to 'ws://127.0.0.1:8880/websocket/tests/hybi/echo' failed: WebSocket is closed due to suspension.
-Test that an open WebSocket does not prevent a page from entering page cache.
-
-On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
-
-
-pageshow - not from cache
-pagehide - entering cache
-pageshow - from cache
-PASS Page did enter and was restored from the page cache
-PASS error event fired
-PASS wasRestoredFromPageCache is true
-PASS close event fired
-PASS wasRestoredFromPageCache is true
-PASS receivedErrorEvent is true
-PASS closeEvent.wasClean is false
-PASS closeEvent.code is 1006
-PASS successfullyParsed is true
-
-TEST COMPLETE
-
+This page should go back. If a test outputs the contents of this page, then the test page failed to enter the page cache.
Comment 1 Ryan Haddad 2016-10-27 17:05:04 PDT
Earliest failure on dashboard was in this range:
https://trac.webkit.org/log/?verbose=on&rev=207967&stop_rev=207953
Comment 2 Ryan Haddad 2016-10-31 16:10:31 PDT
Marked tests as flaky in http://trac.webkit.org/projects/webkit/changeset/208187. Youenn, could you take a look at this?
Comment 3 Radar WebKit Bug Importer 2016-10-31 16:22:19 PDT
<rdar://problem/29035055>
Comment 4 Ryan Haddad 2016-11-01 15:22:55 PDT
These tests are no longer flaky. This may have been fixed with the rollout of r207967 in https://trac.webkit.org/changeset/208200