Bug 163732 - The metrics of variable fonts do not vary when font-variation-settings is applied
Summary: The metrics of variable fonts do not vary when font-variation-settings is app...
Status: RESOLVED DUPLICATE of bug 163093
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: Safari Technology Preview
Hardware: Macintosh macOS 10.12
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-20 08:12 PDT by Laurence Penney
Modified: 2016-10-20 09:27 PDT (History)
1 user (show)

See Also:


Attachments
HTML showing failure in STP, success in Webkit Nightly (337 bytes, text/html)
2016-10-20 08:12 PDT, Laurence Penney
no flags Details
Skia with default 'wdth' setting (14.56 KB, image/png)
2016-10-20 08:19 PDT, Laurence Penney
no flags Details
Skia with low 'wdth' setting (13.01 KB, image/png)
2016-10-20 08:19 PDT, Laurence Penney
no flags Details
Skia with high 'wdth' setting (15.03 KB, image/png)
2016-10-20 08:19 PDT, Laurence Penney
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurence Penney 2016-10-20 08:12:52 PDT
Created attachment 292192 [details]
HTML showing failure in STP, success in Webkit Nightly

When CSS font-variation-settings is applied to a variable font, any metrics changes should be reflected, but they are not.

Tested fonts: Skia, .SFNSText-Regular, .SFNSText-Italic, .SFNSDisplay-Regular

None of my testing of Webkit Nightly exhibited this behaviour.
Comment 1 Laurence Penney 2016-10-20 08:19:09 PDT
Created attachment 292194 [details]
Skia with default 'wdth' setting
Comment 2 Laurence Penney 2016-10-20 08:19:26 PDT
Created attachment 292195 [details]
Skia with low 'wdth' setting
Comment 3 Laurence Penney 2016-10-20 08:19:42 PDT
Created attachment 292196 [details]
Skia with high 'wdth' setting
Comment 4 Myles C. Maxfield 2016-10-20 09:27:28 PDT

*** This bug has been marked as a duplicate of bug 163093 ***