Bug 16373 - REGRESSION: Flash movies show up in other tabs above the page
Summary: REGRESSION: Flash movies show up in other tabs above the page
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Nobody
URL: http://www.smilecms.com/webkit/flash_...
Keywords: HasReduction, InRadar, PlatformOnly, Regression
: 16391 16451 16475 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-09 17:53 PST by Peer Bremer
Modified: 2007-12-20 13:21 PST (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peer Bremer 2007-12-09 17:53:19 PST
Since the latest build of web kit flash movies that are running on a page in an tab show up in newly opened or open tabs of other pages.
Go to above url, it has a very simple flash movie running and then open a new tab, you will see the movie in that tab and it will stay visible even if you browse to another site inside that tab.
Comment 1 Mark Rowe (bdash) 2007-12-09 22:23:28 PST
Which version of the Flash plugin are you using?  I cannot reproduce this with Flash plugin v9,0,115,0 on Leopard.
Comment 2 Peer Bremer 2007-12-09 22:55:26 PST
Using OSX 10.4.11
Flash plug-in Shockwave Flash 9.0 r115
Comment 3 mitz 2007-12-09 23:04:47 PST
I can reproduce this on 10.5.1 with "Shockwave Flash 9.0 r47".
Comment 4 Mark Rowe (bdash) 2007-12-10 00:23:36 PST
<rdar://problem/5638288>
Comment 5 mitz 2007-12-10 18:06:41 PST
*** Bug 16391 has been marked as a duplicate of this bug. ***
Comment 6 Matt Lilek 2007-12-10 20:03:33 PST
I can't reproduce this on Windows (Flash plugin 9.0 r115).
Comment 7 Eluzion 2007-12-11 10:51:45 PST
I'm having the same issue on OS X 10.5.1 with Flash version 9,0,47,0. Never had this issue until about 5-6 days ago when I downloaded the latest (then) Webkit version.
Comment 8 Eluzion 2007-12-11 10:58:42 PST
(In reply to comment #7)
> I'm having the same issue on OS X 10.5.1 with Flash version 9,0,47,0. Never had
> this issue until about 5-6 days ago when I downloaded the latest (then) Webkit
> version.
> 

I updated Flash to 9,0,115,0 and no longer have this issue.
Comment 9 Matt Lilek 2007-12-15 10:38:48 PST
*** Bug 16451 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Acosta 2007-12-16 08:39:12 PST
i've had the same issue with all the nightly builds of the week, but it effectively got fixed when i upgraded... i don't know if this means this should be ignored or if there's actually something to fix thats not 9,0,47 specific
Comment 11 Mark Rowe (bdash) 2007-12-17 06:22:02 PST
*** Bug 16475 has been marked as a duplicate of this bug. ***
Comment 12 donnie 2007-12-17 15:13:51 PST
I'm using the latest version of flash 9.0r115, and OSX 10.4.11 on an Apple PPC G4/867DP-MDD CPU. The problem existed for me using both 9.0r97 and 9.0r115 versions of flash. The problem hit when Safari 3 came out and WebKit's application size increased from 20+ to 60+ mb. No problems with previous Safari 2.0.4 based WebKit. Thanks for looking into the problem. 
Comment 13 Kevin Decker 2007-12-20 13:16:38 PST
(In reply to comment #12)
> I'm using the latest version of flash 9.0r115, and OSX 10.4.11 on an Apple PPC
> G4/867DP-MDD CPU. The problem existed for me using both 9.0r97 and 9.0r115
> versions of flash. The problem hit when Safari 3 came out and WebKit's
> application size increased from 20+ to 60+ mb. No problems with previous Safari
> 2.0.4 based WebKit. Thanks for looking into the problem. 
> 

Comment 14 Mark Rowe (bdash) 2007-12-20 13:21:49 PST
This was fixed with r28902.