Bug 16355 - New GMail interface: Safari constantly downloads items
Summary: New GMail interface: Safari constantly downloads items
Status: RESOLVED DUPLICATE of bug 16240
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://gmail.com
Keywords: GoogleBug, InRadar
Depends on:
Blocks:
 
Reported: 2007-12-08 10:55 PST by Stephen Harbage
Modified: 2007-12-08 13:19 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Harbage 2007-12-08 10:55:29 PST
Summary: 
When I log in and am in any page e.g. the Inbox, Compose, Contacts etc. Safari constantly downloads items, can go download over 1,000 items if left for long enough  according to the status bar! 

Steps to Reproduce:
1. Log into Gmail on Safari
2. When it has loaded the inbox, look at the Status Bar

Expected Results:
I expect the Status Bar to say Done

Actual Results:
But in actual fact it constantly downloads items

Notes:
whereas on Firefox 2.0.0.11 and Camino 1.5.4 this doesn't happen. They just say 'Done' in the status bar. It seems to effect Safari's performance.

Workaround is to click on 'Older Version' in Gmail on the top right

I also added it here: <rdar://problem/5637086>

Tested in Safari 3.0.4 on 10.4.11 and Nighly 28505
Comment 1 Mark Rowe (bdash) 2007-12-08 12:53:53 PST
This is expected as Gmail is constantly doing new XMLHttpRequests.  I think changing this would be considered a Safari UI issue, not a WebKit issue.
Comment 2 Adam Roben (:aroben) 2007-12-08 13:19:41 PST

*** This bug has been marked as a duplicate of 16240 ***