Bug 161756 - REGRESSION (r205569?): 32-bit JSC test timeout: stress/rest-parameter-many-arguments.js.dfg-maximal-flush-validate-no-cjit
Summary: REGRESSION (r205569?): 32-bit JSC test timeout: stress/rest-parameter-many-ar...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-08 13:43 PDT by Ryan Haddad
Modified: 2016-09-08 15:03 PDT (History)
2 users (show)

See Also:


Attachments
proposed patch. (1.21 KB, patch)
2016-09-08 15:00 PDT, Mark Lam
sbarati: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-09-08 13:43:15 PDT
32-bit JSC test timeout: stress/rest-parameter-many-arguments.js.dfg-maximal-flush-validate-no-cjit

https://build.webkit.org/builders/Apple%20El%20Capitan%2032-bit%20JSC%20%28BuildAndTest%29/builds/3632
Comment 1 Ryan Haddad 2016-09-08 13:43:40 PDT
This regressed between r205568 and r205574
Comment 2 Ryan Haddad 2016-09-08 13:44:59 PDT
Possibly https://trac.webkit.org/changeset/205569
Comment 3 Mark Lam 2016-09-08 14:21:01 PDT
Running locally, the test appears to finish just fine.
Comment 4 Mark Lam 2016-09-08 14:53:22 PDT
Looks like the bot is just too slow.  Running the full suite locally on MacPro with the test harness, I don't see the time out at all.  I'll see if I can skip this test configuration for 32-bit x86.
Comment 5 Mark Lam 2016-09-08 15:00:54 PDT
Created attachment 288333 [details]
proposed patch.
Comment 6 Mark Lam 2016-09-08 15:03:31 PDT
Thanks for the review.  Landed in r205664: <http://trac.webkit.org/r205664>.