Bug 160865 - Shadow DOM: Toggling class in `::slotted(.class)` does not trigger style recalc
Summary: Shadow DOM: Toggling class in `::slotted(.class)` does not trigger style recalc
Status: RESOLVED DUPLICATE of bug 164577
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: Safari Technology Preview
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-15 14:37 PDT by Keanu Lee
Modified: 2016-11-10 15:42 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keanu Lee 2016-08-15 14:37:49 PDT
Similar to, but may not be the same as https://bugs.webkit.org/show_bug.cgi?id=160864

Repro: http://jsbin.com/voviqe/1/edit?html,output



Toggling class "special" does not cause a style recalc:

::slotted(.special) {
  background: green
}
Comment 1 Ryosuke Niwa 2016-11-10 15:42:40 PST
Reverse dup'ing into the bug 164577.

*** This bug has been marked as a duplicate of bug 164577 ***