Bug 16004 - FormatBlock leaves first letter incorrectly styled
Summary: FormatBlock leaves first letter incorrectly styled
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://tinymce.moxiecode.com/safari/f...
Keywords: HasReduction, InRadar, ReviewedForRadar
: 21505 (view as bug list)
Depends on:
Blocks: 6627
  Show dependency treegraph
 
Reported: 2007-11-15 12:45 PST by Johan "Spocke" Sörlin
Modified: 2008-11-04 11:31 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johan "Spocke" Sörlin 2007-11-15 12:45:49 PST
Steps to reproduce.

1. Open the attached URL.
2. Place caret/cursor in the second editable paragraph.
3. Press the Format block link.
4. Observe the strange span that got added to the start of block element.
Comment 1 Mark Rowe (bdash) 2007-11-15 20:29:42 PST
Confirmed with WebKit 525.1+ on Mac OS X 10.5.  Thanks for the simple test case!
Comment 2 Mark Rowe (bdash) 2007-11-15 20:31:02 PST
<rdar://problem/5604313>
Comment 3 Justin Garcia 2008-04-23 16:17:54 PDT
I have a fix for this out for review.
Comment 4 Justin Garcia 2008-04-24 10:44:53 PDT
Fixed in http://trac.webkit.org/projects/webkit/changeset/32497
Comment 5 Maciej Stachowiak 2008-11-04 11:31:14 PST
*** Bug 21505 has been marked as a duplicate of this bug. ***